Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Macbook pro: mavericks, 5.2, graphics: nvidia geforce 9600M

I followed the guides from here: https://help.ubuntu.com/community/UEFIBooting#Detect_.28U.29EFI_firmware_processor_architecture and http://www.rodsbooks.com/ubuntu-efi/.

What I have is the following:

/dev/sda

  • apple partitions
  • /boot
  • / (root)
  • swap

When installing ubuntu, I did not install the boot loader during installation but did so in a chroot environment after installing grub-efi. I installed grub to /dev/sda1 (efi) which created the grub64.efi file in efi/ubuntu. This allows the refined boot manager to bring up grub and select ubuntu however, the graphics does not work. Even after adding nomodeset and removing quiet/splash from the kernel parameters.

Any ideas on what could be wrong?

To be clear, if I remove quiet/splash, I can see all the text startup messages being printed out however, the display manager doesn't appear to start (the screen stays black). Oddly enough though, the ubuntu startup sound can be heard.


should have specified this better.

As per my answer I was able to get ubuntu to boot with the nvidia drivers however, the one thing happening now is that I am not getting the virtual ttys (ctr-alt-f[1234..]). Attempting to switch to one of these results in a black screen

share|improve this question
    
It is probably a bug in Nouveau. Did you install the Nvidia proprietary drivers? –  bain Jun 1 at 1:10
    
Macbook, Macbook Pro, or Macbook Air? –  pilona Jun 1 at 1:29
    
Please post bootloader configuration and GPT partition flags. –  pilona Jun 1 at 1:31
    
Partition flags are not an issue; do not change them, since doing so could add problems. It's conceivable that adding or changing kernel options in the bootloader will improve matters, but any such change will be highly model-specific. –  Rod Smith Jun 1 at 15:39

2 Answers 2

You could try messing with your X options. Unfortunately, this isn't a cut-and-dried repair technique, and it requires knowledge that's no longer common in the Linux community. An outline of what to do is:

  1. Boot to single-user mode by adding 1 or single to the kernel boot options in your boot loader.
  2. Once the computer has booted, log in using text mode and type Xorg -configure. This will generate a file called /root/xorg.conf.new (or something like that; I don't recall the precise filename).
  3. Copy /root/xorg.conf.new to /etc/X11/xorg.conf
  4. Edit /etc/X11/xorg.conf to set the video driver and other options you want to use.
  5. Test it by typing startx.
  6. When it works, reboot (not into single-user mode).

Step #4 is admittedly vague, but it's the key to the operation. Doing a Web search on xorg.conf turns up lots of sites that describe the file in various levels of detail. You can probably ignore most of the options; you probably just need to set the right video driver to get around your problem, although you may need to set some driver-specific options. With an Nvidia chipset, you have three driver choices: nv, nouveau, and nvidia (the last of these is the proprietary Nvidia driver, which you might not have installed).

share|improve this answer

Inexplicably, I managed to get to boot successfully. Fluke? Was I by chance using nomodset instead of nomodeset?

Anyways, I booted and installed the nvidia drivers. I can now boot successfully everytime.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.