Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have triple boot (XP, 7, Ubuntu in Wubi) and today my Windows 7 got messed up and request I insert the installation CD and do a repair. When I did the repair, my boot screen got messed up and I no longer have Ubuntu to choose to boot from.

I have used EasyBCD to add XP back to the boot screen, but I couldn't use it to add Ubuntu back.

share|improve this question
    
I have used the Boot Repair bootloader, but it did not solve the problem. If I run the Ubuntu installation again, will that fix the problem? Will that reset the software configurations I have made? –  user287187 May 31 at 20:57
    
Yes, run the ubuntu installation directly from a live disk and do not install using wubi as it is not a recommended method of installation. See below. –  mchid Jun 8 at 1:55

5 Answers 5

You have to reinstall the GRUB bootloader:

  • Grab a USB stick and copy all of its files to the local hard disk
  • Download the Boot Repair live CD
  • Download and run UNetBootin for Windows
  • In UNetBootin: (Offical Instructions) Screenshot
    • Select the Diskimage option (1)
    • Click on the ... button and select the downloaded .iso file (2)
    • Select the drive letter of your USB device next to Drive: Make sure its the right one!!! (3)
    • Click OK
    • Wait for the process to complete
  • Reboot
  • During POST (when you see your hardware manufacturers logo) press F12, select your USB Stick (using arrow keys) and press Enter
  • Within "Boot Repair": (Official instructions)
    • Choose your language,
    • Connect internet if possible
    • Click "Recommended repair"
share|improve this answer
    
I have already done all that and it did not work :(.........This is my Ubuntu Pastebin link.......... paste.ubuntu.com/7561275 –  user287187 May 31 at 20:42
    
Ufff... You didn't say you were using Wubi. Try replacing your "<Windows 7 C:>/boot.ini" file with this: paste.ubuntu.com/7566219 (Make a backup of that file first and don't start EasyBCD) then reboot select "Windows XP" then select "Ubuntu". (I haven't used Wubi in a very long time so don't be disappointed if it doesn't work right away). Also: If it works do yourself a favour and migrate Ubuntu to its own partition. –  alexander255 Jun 1 at 14:21
    
Also try /ubuntu/winboot/wubildr.mbr instead of \wubildr if it doesn't work –  alexander255 Jun 1 at 15:02
    
My Windows 7 bootloader is "\Windows\system32\winload.exe" , how will I add the boot.ini ????? –  user287187 Jun 1 at 16:43
    
Wasn't taking about your Windows 7 bootloader... Quote: [...]then reboot, select "Windows XP" [in the Windows 7 boot menu] then select "Ubuntu" –  alexander255 Jun 1 at 18:02

Okay since this is about Wubi and you are using EasyBCD anyways:

  1. Boot Windows 7
  2. Start EasyBCD
    Steps
    1. On the right side select "Add new entry" (1)
    2. In the "Portable/External media" section select the image type "Raw Hard Disk Image" (2)
    3. Recommended: Enter a useful name
    4. Select the file <Ubuntu installation path>\winboot\wubildr.mbr as "Path" (3)
      In your case Ubuntu is probably installed in E:\ubuntu which would result in the path being E:\ubuntu\winboot\wubildr.mbr - it might be slightly different however...
    5. Click "Add Entry" (4)
  3. Reboot
  4. In the Windows Boot menu select Ubuntu
  5. Hope
share|improve this answer

My Advice is for you to use the commandline commands from a console screen via the Live CD.

First boot to live CD. Choose the Try Ubuntu option. Enter the Terminal Console. Then run these steps:

Fix grup boot:

1) boot to the Ubuntu installation disk
2) Run the "Try Ubuntu" option
3) Bring up a terminal (Launch search "terminal")
4) Run these commands (exactly):

a) sudo mount /dev/sdaX /mnt  # Make "X" the partition that has Ubuntu installed (i.e. /dev/sda2).
b) for i in /sys /proc /run /dev; do sudo mount --bind "$i" "/mnt/$i"; done
c) sudo chroot /mnt
d) update-grub
e) if no errors skip this "e" section
    grub-install /dev/sdX (x is the hard drive that has linux installed (i.e. /dev/sda)
    update-grub

The key to your specific case is the "update-grub". However, you have to have that installation active when you run it. Therefore the other steps are important.

share|improve this answer
    
there is no grub to fix with wubi –  mchid Jun 8 at 1:38

The easiest way to fix this is to scrap wubi and do a fresh install of Ubuntu to your hard drive from a live disk as the wubi method of installation is no longer recommended (for obvious reasons).

There are tons of youtube videos that can show you how to do this on a system with 3 or more partitioned operating systems.

Boot your computer from an Ubuntu Live Disk and select to try Ubuntu with out installing.

Use the gparted application to create a separate partition formatted to ext4 for your installation and another separate partition formatted to linux-swap that only needs to be 2-4GB.

Set up a working internet connection and then click on the install Ubuntu icon from the desktop.

When you get to the portion of the installation where it asks you what where and how to install Ubuntu, "along side" or to "replace Windows", go to the bottom and choose "something else".

From this screen, right-click on the ext4 partition you recently created. Choose the mount point "/"

Choose continue, yes to make changes, and continue with the rest of the installation.

share|improve this answer

You Use Boot-Repair(https://help.ubuntu.com/community/Boot-Repair)

And use it to re-enable GRUB. Just Follow the steps on the Help Page

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  amc May 31 at 19:02
1  
he's using wubi within windows so there was no grub to begin with –  mchid Jun 8 at 1:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.