Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Like many other natty users on a university/academic network, I'm experiencing annoying frequent disconnects/hangs/delays.

See, for instance here.

I would like to learn how to add fast_reauth=0 to the wpa_supplicant.conf file.

This file, it seems, does not exist by default, and needs to be manually created first: README

You will need to make a configuration file, e.g. /etc/wpa_supplicant.conf, with network configuration for the networks you are going to use.

Further, I installed wpa_gui which probably needs to be launched with parameters, else it's pretty blank...

What I'm hoping for is this:

That creating a wpa_supplicant.conf file with fast_reauth=0 in it, saving it to the relevant path, will work and make my uni wireless (more or even completely) stable.

I read mixed reviews about wicd (as an alternative to the network manager).

Also note that on my basic wlan at home (with bog-standard wpa encryption) the connection is stable.


share|improve this question
please help. I know, obviously, how to create and text-input a file. What I don't know and would like to know is: a) is this still relevant in natty, and b) is this the right thing to do / what steps exactly must I take to test this make-shift solution on my laptop? (I can't tell you how annoying (and time-killing) this is. If this also happened at home... don't want to think about it... am even considering to boot xp (this is how desperate I might be at the end of today trying to work from the library...)). – nutty about natty Jun 8 '11 at 9:31
suddenly, late afternoon, the library is still just as full as it was before, my wireless connection has decided to remain stable for a sustained period (over an hour ?). Earlier today, I had to manually reconnect (takes two clicks and about 3.5 seconds) virtually every minute / every time I took a short break to read in a (physical / paper) book & then had to browse again; audio / video streams would last not more than a minute or two and then stall... In essence, there seem to be periods of wlan-stability and other periods of wlan-craziness... who or what decides the type of period I'm in ? – nutty about natty Jun 8 '11 at 15:42
connection lost again; manual reconnect due again... – nutty about natty Jun 8 '11 at 15:51
To clarify: the problem isn't solved, the question is not answered, I'm still clueless / am still looking for reliable and detailed instructions. Would be great to hear from one of you! thanks. – nutty about natty Jun 16 '11 at 18:12
pps: Would anyone hazard to say that switching to a proprietary driver (I'm on an IBM Thinkpad X41) would help / make the problem "go away"? – nutty about natty Jun 21 '11 at 6:01

Switching to another driver is very unlikely to solve your problems but as always this is an opinion. I've had too many people complain at me to make definitive statements...

The previous comment about a Fedora setup applies to Ubuntu too. Here is what fi.epitest.hostap.WPASupplicant.service looks like on Fedora:

Exec=/usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -B -u -f /var/log/wpa_supplicant.log -P /var/run/

The issue is the time it would take to write a good, clear explanation of how to do what you want is large and worse there are no guarantees that this would even fix your problem (worst case scenario is that things are made worse and a half working install is rendered inoperable). Most likely you will get short/difficult or cookie cutter answers because that's all the time someone else could spare. It's not that you're doing anything wrong - it's that what you are trying to do is only easy for experts. Hopefully someone with more time will help you piece things together...

As a technical user I really would like to help but it is clear that this is going to take up quite a bit of time but perhaps I'm just slow :-) My advice to you is set a time limit - say "I'm going to spend 45 minutes on this problem in total" and if you find yourself taking even a minute more than that please stop! I hate it when I see new Linux users chew up hours of their life on nasty issues :( Good luck!

share|improve this answer
THANKS "Anon" - your answer is the most (honest and) useful thus far, for me. With exam preparations on my desk (and no time immediately after either up until fall/autumn), I will put this issue aside (and hope for progressions rather than regressions in future ubuntu updates...). I like ubuntu (& linux) too much to go back to (booting) xp, even though the former ought to be the (more) stable, reliable, dependable one... and in terms of using computers today, internet stability is quite key, don't you agree? But at least on "simple" (home) wlan's, the connection is stable: sanity preserved. – nutty about natty Jun 26 '11 at 6:24

try this

it is written for ethernet eduroam but it might work with wireless too. You should change few things (dont have time right now to tell you what) but you will be able to see that on your own. if You cant post it here!

share|improve this answer
summerb0y, many thanks for your reply. I already tried a root / su search for the .conf file but couldn't find it. Does it perhaps already exist on my system? Is it hiding from me / am I too st*pid to find it? Is it because it contains plain-text passwords? – nutty about natty Jun 8 '11 at 14:44


  1. uninstall network-manager (and reboot)
  2. install package wpasupplicant
  3. add file /etc/wpa_supplicant/wpa_supplicant.conf with information about your networks, e.g.:

  4. edit the wlan section in /etc/network/interfaces :
    auto wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Your wireless interface might also be called something else e.g. wlan1. You can restart the networking with sudo /etc/init.d/networking restart

hope it helps,

share|improve this answer
I read somewhere... that uninstalling network-manager was unnecessary and might cut off one's bridge to the internet for longer than one might like ;) Rather than uninstalling, I think it was either taking out the startup entry or disabling it otherwise... Install wpa_supplicant? Well, I think it's been installed by default (in natty) - at least I can find various parts of it on my system (except for the *.conf, of course). Is there a simple copy & paste (line by line, I guess) method from network manager to the *.conf file? Do I need to convert passwords / chmod file read permissions? Thanks! – nutty about natty Jun 21 '11 at 5:54

The best source is probably your system's very own online reference. From a terminal, type:

man wpa_supplicant.conf

Use Page Up and Page Down to navigate it, and press q to quit.

share|improve this answer
Thanks, jpaugh - hmm, seems reasonably succinct, especially in comparison to the very lenghty "Example wpa_supplicant configuration file" & the Readme... I still feel a bit overwhelmed. Am looking for a simple elegant solution, and it seems to be getting more involved by the minute... and time-consuming, too!!! – nutty about natty Jun 21 '11 at 5:59

It is not necessary to uninstall network manager. If you ever look at a Fedora setup and do ps axww | grep [w]pa_supplicant you will see that wpa supplicant makes use of a configuration file because it is launched with a command line option setting one. Since it is launched via dbus the file you will need to edit /usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service and add a -c option to the config file. As mentioned in an earlier comment you will need to add fast_reauth=0 to the .conf file. For the change to be picked up you will need to relaunch wpa_supplicant (the "easiest" thing to do is reboot) then run the ps command to see that the option has been picked up. Note that for me fast_reauth=0 did not fix my problems on eduroam...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.