Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using a Realtek RTL8192ce wlan card on Ubuntu 10.04 and Ubuntu 14.04. Previously the built-in kernel module 'rtl8192ce' worked fine. There'd be some occasional, random blips, but I could get online just fine. Recently, I set up this computer in a new apartment, but could not connect to the local network at all. Based on posts on this site, I found adding a config file for this driver module helped. I added

options rtl8192ce ips=0 fwlps=0

to the file

/etc/modprobe.d/rtl8192ce.conf

These options have to do with powersaving features of the card. I'm not really sure that's my problem, but it did do something. Now I can connect to the local network, but once connected, I can't reach my router's local IP or ping it or ping external sites. I've tested this with another router too.

I'd like to be using commands rather than Unity desktop GUI so I can get some specific error messages or feedback. Can someone advise me on or point to a page about turning on and off wlan0 and switching between networks. How can I figure out what's wrong? I feel like if I knew the shell commands for controlling networking and knew more about the kernel module in question, especially more options I can set, I could see more clearly what the problem is.

Thanks in advance.

Cheers, Ryan

PS: This is the output of 'lspci -vvnn' that regards the wifi card:

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe 
Wireless Network Adapter [10ec:8178] (rev 01)
Subsystem: ASUSTeK Computer Inc. Device [1043:84b6]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- 
SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort-
SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 16
    Region 0: I/O ports at d000 [size=256]
    Region 2: Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: rtl8192ce

UPDATE: This is the output of 'sudo lspci -vvnn' for the wifi card:

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter [10ec:8178] (rev 01)
Subsystem: ASUSTeK Computer Inc. Device [1043:84b6]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 16
Region 0: I/O ports at d000 [size=256]
Region 2: Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
    Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000  Data: 0000
Capabilities: [70] Express (v2) Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
        MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <64us
        ClockPM+ Surprise- LLActRep- BwNot-
    LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Not Supported, TimeoutDis+, LTR-, OBFF Not Supported
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis+, LTR-, OBFF Disabled
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
         Compliance De-emphasis: -6dB
    LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
Capabilities: [100 v1] Advanced Error Reporting
    UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
    CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
    CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
Capabilities: [140 v1] Virtual Channel
    Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
    Arb:    Fixed- WRR32- WRR64- WRR128-
    Ctrl:   ArbSelect=Fixed
    Status: InProgress-
    VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=01
        Status: NegoPending- InProgress-
Capabilities: [160 v1] Device Serial Number 01-91-81-fe-ff-4c-e0-00
Kernel driver in use: rtl8192ce
share|improve this question
    
Did /etc/modprobe.d/rtl8192ce.conf already exist for you? I don't have that file and am using the built-in module, with decent success (some drops in the connections, but bearable). –  saiarcot895 May 31 at 4:03
    
No I had to create it and add a single line. I'm not really sure how the modules interact with the kernel and the config files so I can't say more than that. That's my question in part; how does this stuff work? How can I figure out why your machine can cope with this driver, but mine can't? Thanks for your reply! --Ryan –  Ryan Schram May 31 at 4:47
    
This seems simple, but can you ping your DNS, gateway, or anywhere on network, and if you can hit your LAN, can you ping out? If you can't you might have to set DNS to something simple like 8.8.8.8 (Google DNS) and see if that works. If it is a hardware problem, sorry for the waste of time. (That access denied looks like it may be of some concern too) –  No Time May 31 at 5:07
    
@NoTime: The access denied is likely because sudo wasn't used in the command. –  saiarcot895 May 31 at 11:03
    
@NoTime Thanks for your tips. I can't ping any IP address on the local network, 192.168.1.[0..255], although the Unity GUI icon says the card is connected to the router modem. And I can't connect to external sites either. When connected to this router via Ethernet cable, I can do both. \@saiarcot895 Thanks! I've updated my post with the full report. –  Ryan Schram May 31 at 20:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.