Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having issues currently with my floppy drive. I am able to see it in the devices list, but I cannot get it to mount. I am using Ubuntu 14.04. I get a timeout error when using the udisks --mount /dev/fd0 command.

enter image description here

Are there any workarounds or ways I can either get it to work or remove it from the device menu? Either answer is fine.

Side note: I have tried disabling it in the BIOS menu, but there's no option for it. Also, removing it from the computer isn't an option, it is still "detected" by the OS.

share|improve this question
    
Are you sure the floppy drive still works? Floppy drives haven't been standard on PCs for a decade, I would guess it's broken, or the disks have decayed. –  bain May 30 at 22:37
    
I've actually tried it in an older WinXP box, and it reads and writes just fine. At this point, I'm looking for a way to disable it. Is there something in /etc/fstab? –  Andrew Fischer May 30 at 22:38
1  
See How to disable floppy drive? –  bain May 30 at 22:39
    
These instructions haven't removed the floppy from any lists, nor the desktop entry on xfdesktop. However, the entry now gives an "invalid block device" error when opened. Anything else to recommend? –  Andrew Fischer May 30 at 22:50
    
Can you confirm lsmod|grep floppy shows nothing and ls -l /dev/fd0 shows nothing? If so, can you create a new account and log in and see if the floppy drive shows up. Also does grep fd0 /etc/fstab show anything? –  bain May 30 at 22:54
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.