Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I am trying to install the latest version of Phatch using the .deb for ubuntu available on their site and installing through the Ubuntu Software center. I get the message "Cannot install blender".

So I try to install blender (still in USC) and I get the following:

The following packages have unmet dependencies:

blender: Depends: libavcodec-extra-52 (>= 4:0.6-1~) but 4:0.6.2-1ubuntu2 is to be installed
         Depends: libavdevice-extra-52 (>= 4:0.6-1~) but 4:0.6.1-2ubuntu1 is to be installed
         Depends: libavformat-extra-52 (>= 4:0.6-1~) but 4:0.6.1-2ubuntu1 is to be installed
         Depends: libavutil-extra-50 (>= 4:0.6-1~) but 4:0.6.2-1ubuntu2 is to be installed
         Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
         Depends: libjpeg62 (>= 6b1) but 6b1-1ubuntu1 is to be installed
         Depends: libstdc++6 (>= 4.5) but 4.5.2-8ubuntu4 is to be installed
         Depends: libswscale-extra-0 (>= 4:0.6-1~) but 4:0.6.1-2ubuntu1 is to be installed
         Depends: zlib1g (>= 1:1.1.4) but 1:1.2.3.4.dfsg-3ubuntu3 is to be installed

When I try to install any of the missing packages in Synaptic it fails: for example 


libavdevice-extra-52:
  Depends: libavcodec-extra-52 (<4:0.6.1-99) but 4:0.6.2-1ubuntu2 is to be installed
 Depends: libavformat-extra-52 but it is not going to be installed
 Depends: libavformat-extra-52 but it is not going to be installed
  Depends: libavutil-extra-50 (<4:0.6.1-99) but 4:0.6.2-1ubuntu2 is to be installed

It also wants to uninstall a lot of programs including audacity, vlc etc.

So is it actually possible to install blender and therfor Phatch on Ubuntu 11.04 and if so how?

share|improve this question
    
Could someone with more rep than me please add the tag "Phatch" to this question. I don't have enough rep to create new tags –  Ash G Jun 7 '11 at 12:57

1 Answer 1

up vote 1 down vote accepted

Install the phatch package from the 11.04 repository, that's the most current one (0.2.7.1-1).

Some of the packages are too old for 11.04 but look like they are for 10.04, e.g. libavdevice-extra-52 and libavformat-extra-52.

Maybe you don't have the multiverse channel enabled and the packages are still there from before you upgraded an older version.

If you type

 apt-cache policy libavdevice-extra-52

in a Terminal window that tells you where the package is from.

share|improve this answer
    
When I try to install from Synaptic I get "phatch: Depends: phatch-cli but it is not going to be installed" and when I try installing phatch-cli I get" phatch-cli: Depends: python-pyexiv2 but it is not going to be installed" So I installed python-pyexiv2 which went ok then I went back to install Phatch again with the error message saying it needs phatch-cli. When I try to install phatch-cli it wants to remove python-pyexiv2 which I just installed! –  Ash G Jun 8 '11 at 1:41
    
output from: apt-cache policy libavdevice-extra-52: "libavdevice-extra-52: Installed: (none) Candidate: 4:0.6.1-2ubuntu1 Version table: 4:0.6.1-2ubuntu1 0 500 debian.nctu.edu.tw/ubuntu natty/multiverse i386 Packages" I then went to install it using apt-get: "libavdevice-extra-52: Installed: (none) Candidate: 4:0.6.1-2ubuntu1 Version table: 4:0.6.1-2ubuntu1 0 500 debian.nctu.edu.tw/ubuntu natty/multiverse i386 Packages" So it looks like I have somehow ended up with broken packages –  Ash G Jun 8 '11 at 1:42
    
I ran sudo apt-get install -f to fix the broken packages and nothing happened: "Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded." –  Ash G Jun 8 '11 at 1:44
    
It looks like your mirror didn't get any updates since 2011-Feb-27 so you are using natty from a few days before alpha3. Use another mirror. –  Florian Diesch Jun 8 '11 at 7:22
    
That did it! Thanks –  Ash G Jun 9 '11 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.