Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrade to Ubuntu 14.04 my mouse pointer is blinking and some time it's disappear, I don't know why this happening

I search lots of for this issue and I get some results but unable to get solutions.

This is my display in Settings -> Display

enter image description here

share|improve this question
    
For my laptop, the solution was ubuntu 12.04 –  Charles Green Jun 8 '14 at 18:10

3 Answers 3

up vote 13 down vote accepted
+25

Disable the "Unknown Display" in Display settings.

share|improve this answer
    
How to disable, please see the screenshot and give me steps –  Dipak Panchal Jun 9 '14 at 5:44
    
Klick on the "Unknown Display" und move the according "On/Off" Slider to "Off". –  Nodebody Jun 9 '14 at 7:54
    
there are two on/off button (see in screenshot above) 1. Built-in-Display and 2. Sticky Edges. When select Unknown Display from Launcher Placement - then nothing happen, I do all off but still not working. –  Dipak Panchal Jun 10 '14 at 1:20
    
Could you post a screenshot of where you selected and disabled the Unknown Display? –  Nodebody Jun 16 '14 at 18:34

In your first screen shot, where you have a pink/red rectangle and a green one, this screen indicates two monitors, being one for each color. It's like your ubuntu is seeing two monitors. This second one, indicated by the green square, is what some people told you here as being the Unknown Display.

You should click this green square in order to see the configurations for this display. When you do so, your "Built-in display" button will be now named "Unknown Display" and you should set this to off.

Setting it to off will turn the green screen to gray.

share|improve this answer

I also had the same problem together with two duplicate screens showing inside a particular workspace while switching them. After I disabled the unknown display this problem was resolved too. I do not know why that option is on my default anyways.

share|improve this answer

protected by Community Jan 6 at 12:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.