Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I access and enable more icons to be in the system tray?

I was using the android-notifier-desktop indicator on my Lucid 32bit installation comfortably, but when I changed to Natty amd64, the same setup does not seem to work.

Summary of things:

  1. android-notifier-desktop_0.5.1-0-amd64.deb is installed.
  2. I can see a java android-notifier-desktop.jar running in my ps list.
  3. there is no unity-panel indicator for the notifier (this is the problem).
  4. I had also added the gnome-panel at the bottom of my desktop;
    Trying to "add to panel..." here also does not show the notifier as an option.

Has anyone setup this notifier on Natty amd64?
Am I missing something here?
Are there any other ways to get the notifier showing?

share|improve this question
    
What to do with questions that describe known bugs? this has been reported on Google Code and as such is now closed. To follow developments, workarounds, and solutions for this bug please use their bug tracker system. –  Marco Ceppi Jun 7 '11 at 13:11
add comment

closed as off topic by Marco Ceppi Jun 7 '11 at 13:12

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

Ok, there is Issue 383 already filed for this.
But, it does not yet solve the problem :-)
If you are interested in getting this to work, login to code.google.comand click on the enter image description here icon.

share|improve this answer
add comment

Ubuntu 11.04 has disabled the traditional notification area, applications are expected to use indicators.

But the old system is still there and can be activated by hand. You can whitelist an application to let it use the notification area by changing a gconf key. You can get your current values with this command:

gsettings get com.canonical.Unity.Panel systray-whitelist

['JavaEmbeddedFrame', 'Wine', 'Skype', 'Dropbox']

The second line shows the results in my computer, it's not part of the command.

You can add your app with the following command:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Skype', 'Dropbox', 'YOUR_APP']"

Or just use ['all'] to enable any program to use it:

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
share|improve this answer
    
this sounds promising, I'll look at it. Thanks. –  nik Jun 9 '11 at 4:18
add comment

Just log in once to the 'Ubuntu (Classic)' desktop, and configure it. Then, it will run like normal with Unity. You won't see the icon, but the notifications will appear as before. You can switch between Unity and Classic any time you need to change it's configuration. The icon is pretty much unnecessary once you set it up. I did this and it works perfectly.

share|improve this answer
    
I recall it was useful on my Lucid installation. Would like to get it working very much. –  nik Jun 9 '11 at 4:19
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.