Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I open gvim to edit a file, after about 10 or 15 seconds, the terminal window from which I typed gvim foo.txt gives the error:

** (gvim:2581): WARNING **: Unable to register window with path '/com/canonical
/foo/3C00024': Timeout was reached

This doesn't prevent me from continuing to edit with vim, but makes me think something isn't configured correctly. What does this mean?

I'm running Ubuntu 11.04, and I've installed Vim with apt-get install vim vim-gnome vim-nox etc. (Not sure exactly which packages.)

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

It means the menus (File, Edit, Tools, Syntax, Buffers, Window, Help) will not be displayed on hovering at the top of the screen when the gvim window is the active window.

It is a bug and has a work around.

gvim(){ /usr/bin/gvim -f "$@" & true; }
share|improve this answer
1  
The problem with this workaround is, that "you have running jobs" when try closing the shell while leaving gvim open. At least when you use the zsh. So try this when using zsh: gvim(){ /usr/bin/gvim -f "$@" & true;disown } and I didn't observed this error message without loss of any comfort. –  math Dec 6 '11 at 10:46
    
Could you possibly also mention that that line should go in the shell preferences file (maybe mention a few, ie. .bashrc) –  puk Feb 23 '12 at 3:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.