Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here's the problem: Everytime I close gedit all of my own (LaTeX)snippets are lost when I launch it for the next time. Default snippets are still available and working.

What I tried so far:

  • Restart my computer (I know, this is crude, but sometimes it helps.)
  • Re-install gedit-plugins (apt-get purge for removal, even cruder.)
  • Export my own snippets within the "manage snippets menu" and import them. The reimport didn't work. I can point the tar.gz an click on "open" but nothing happens.

I'm using Ubuntu 14.04 LTS on a Core i5.

Thanks in advance, Markus

share|improve this question

I had the same problem and found out that ~/.config/gedit is not enabled for writing. So you have two options.

  1. This is cumbersome, but you could always start gedit as super user via terminal sudo -b gedit.

  2. You can change the permissions of ~/.config/gedit and all of its contents:

    sudo chmod -R 760 ~/.config/gedit

share|improve this answer
The second solution is clearly preferable. Another option is to change the owner of the gedit folder. Why is it root's property anyway? Bug or feature? – Marc Jan 9 at 23:39

Already tried to reinstall gedit or the latex plugin?

Install (if already it isn't) the synaptic package manager using this commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install synaptic

Then run synaptic and type in the search box for gedit, right click in the package name an click on "mark for reinstallation". Do the same with the latex plugin and then apply.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.