Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using:

  • PuTTY [release 0.63]
  • TightVNC Viewer for windows [version 2.7.10]
  • windows server 2012 r2 on Windows Azure.

To connect remote desktop of my Ubuntu machine on windows azure [Ubuntu 13.10]. I have installed desktop and get the result of the command vncserver -geometry 1440x900 like below:

New 'paulubuntu:1(azureuser)' desktop is paulubuntu:1
Starting applications specified in /home/azureuser/.vnc/xstartup
Log file is /home/azureuser/.vnc/paulubuntu:1.log

and then open the the vncviewer, enter my password correctly, the only screen display to me is a gray screen with the following 3 lines in it:

  1. Accept clipboard from viewers.
  2. Send clipboard to viewers.
  3. Send primary selection to viewers.

Is there some issue to display my desktop? I am newbie to Linux system, any idea would be appreciated.

share|improve this question

If you want to connect to "your desktop" via VNC, you should probably use the default 'Desktop Sharing' application (vino-server) that is provided as part of the ubuntu-desktop package, rather than a separate vncserver session. You can configure it by entering 'Desktop Sharing' in the dash search, or from the command line by running vino-preferences.

Standalone vncservers (such as vnc4server and tightvncserver) use their own session startup file located at $HOME/.vnc/xstartup, and the default file that ships with the package just starts a simple X terminal window on a plain gray root window (which is probably what you're seeing).

You can find a sample $HOME/.vnc/xstartup file in the Ubuntu Community Help Wiki at VNC/Servers - Customizing your session which you can copy and edit to start your chosen desktop session - which must sorrespond to one of the available .desktop files in your /usr/share/xsessions directory. Note that the ubuntu-2d session referred to in the Wiki is no longer available in 13.10.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.