Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem in Ubuntu 11.04 that Internet cannot work when i run my PC , i have dsl in my computer and when Internet cannot run i pull Cable and put it again these problem every time when i run pc , and many users Complain from this problem . what is the solution?

share|improve this question

3 Answers 3

It is very difficult to be helpful when you provide so very little information. You should always try to provide as much as you can.

But you say that many users complain about this and since it is very uncommon for people to have problems with cabled network in Ubuntu, it is possible that your internet service provider uses something called PPPoE. In that case, you would normally have to enter a username and password in order to connect to the service.

In that case, click the network icon in your upper panel and select "Edit connections". You'll get a new dialog and the right-most tab is called DSL. Click Add and another dialog will appear. In the DSL page of that page, you can enter username, service and password. Your internet service provider can give you that information. You can choose a name for the connection and decide if it should be connected automatically.

I think that should be it. If it doesn't work, but you do need a username and password, then that is the right place to enter all the details, but you'll need to get some support from your internet service provider.

Please confirm if it does work.

share|improve this answer
1  
Here, have a "saint" badge for attempting to answer that question. –  poolie Sep 12 '11 at 7:16

Have you tried in terminal running sudo dhclient just in case or in the Unity gui clicking AGAIN on the connection made (Tipically auto eth0, eth1, etc...)

share|improve this answer
    
i didn't try to use this command but when when i click AGAIN on the connection made (Tipically auto eth0, eth1, etc...) ,The problem is not resolved and sometime auto eth0, eth1, etc... not found. –  user9243 Jun 7 '11 at 23:34
    
Lets see, what I first would do is: 1. Send a ping to google just to check connectivity. like ping google.com. Am assuming you are connected directly to the internet and not through some router or lan network. 2. Send a ping to the primary dns of your ISP company. 3. Do tracepath google.com just to see where the routing is dying. 4. Check cable 5. Check adsl modem 6. Verify Network Card 7. If you have another PC, try to test the same cable in the same adsl modem. Just in case –  Luis Alvarado Jun 8 '11 at 0:32
    
i think problem in Ubuntu 11.04 only as in windows Internet work perfect, and when i setup Ubuntu 10.10 Internet work good –  user9243 Jun 8 '11 at 1:20
    
Did you install the proprietary drivers. Depending on your PC this need to be installed or not. Press ALT+F2 and type jockey-gtk this should bring the proprietary driver window and you should see there if there is any drivers that still need to be installed. Like Wireless Broadcom, Nvidia, etc.. –  Luis Alvarado Jun 8 '11 at 1:36

You can actually look into trying to renew ip command:

$ sudo dhclient -r

-r flag explicitly releases the current lease, then..

$ sudo dhclient 

Obtains fresh/new IP

Hope it may help you

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.