Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

i am using ubuntu 14.04 and in terminal when i run: sudo apt-get update

my terminal gives me an error of:

E: Malformed line 1 in source list /etc/apt/sources.list.d/google.list (dist parse)
E: The list of sources could not be read.

when i was trying to install google chrome, my internet connect became lost during the download and didn't install correctly, now i cannot get apt-get update to operate at all. i am fairly new to using any type of linux OS, so please help me fix this issue.

share|improve this question

marked as duplicate by Avinash Raj, karel, minerz029, Eric Carvalho, waltinator May 29 at 14:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Does it fix itself if you use sudo apt-get update? –  IQAndreas May 29 at 4:40
    
@AvinashRaj This question is slightly different. There is a problem in one of the items inside of sources.list.d instead of in the "primary" sources.list file. The answer is going to vary slightly. –  IQAndreas May 29 at 4:46
    
@IQAndreas Did you can't figure out the solution from the original question for this? –  Avinash Raj May 29 at 4:48

1 Answer 1

Remove the offending file: sudo rm /etc/apt/sources.list.d/google.list and start the process from scratch.

share|improve this answer
    
i tried everything i could think of to remove that file and nothing worked, luckily that command just fixed it thank you so much for the quick response. –  user286362 May 29 at 4:44
    
Well, then please consider marking the question as answered. –  sмurf May 29 at 6:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.