Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to enable innodb on my ubuntu server 10.04 and having tons of problems, I have tried posting questions everywhere and I have no answers....i tried this

show variables like "%innodb%";
| Variable_name         | Value |
| have_innodb           | NO    |
| ignore_builtin_innodb | OFF   |

so it seems like it is not installed or something but i keep reading its installed by default

show engines;
| Engine     | Support | Comment                                                        | Transactions | XA   | Savepoints |
| MyISAM     | DEFAULT | Default engine as of MySQL 3.23 with great performance         | NO           | NO   | NO         |
| MRG_MYISAM | YES     | Collection of identical MyISAM tables                          | NO           | NO   | NO         |
| BLACKHOLE  | YES     | /dev/null storage engine (anything you write to it disappears) | NO           | NO   | NO         |
| CSV        | YES     | CSV storage engine                                             | NO           | NO   | NO         |
| MEMORY     | YES     | Hash based, stored in memory, useful for temporary tables      | NO           | NO   | NO         |
| FEDERATED  | NO      | Federated MySQL storage engine                                 | NULL         | NULL | NULL       |
| ARCHIVE    | YES     | Archive storage engine                                         | NO           | NO   | NO         |
7 rows in set (0.00 sec)

I dont see it in the output and when trying to install Social Engine I get this:


share|improve this question
How did you install MySQL? – Marco Ceppi Jun 7 '11 at 0:53
I used linode server with preconfigured lamp "Originally created using Ubuntu 10.04 LTS and 'LAMP Stack' StackScript at revision 160" – Tamer Jun 7 '11 at 1:08
in a virtual machine with 10.04.2 installed sudo tasksel install lamp-server MySQL installs with InnoDB engine available. This might be something you have to take up with Linode Support – Marco Ceppi Jun 7 '11 at 1:11
thanks ...on the phone with them now – Tamer Jun 7 '11 at 1:18
Let us know if it was a problem with Linode - if not we can try to help you troubleshoot further :) – Marco Ceppi Jun 7 '11 at 1:19

here is the solution

enabling the following two InnoDB directives in your /etc/mysql/my.cnf file appears to have resolved this issue:


When restarting your MySQL server, there appears to have been some lingering processes so the mysqld.sock file wasn't being created correctly. As you saw in Lish, I forcefully killed the lingering processes using the kill command, and then restarted MySQL normally with service mysql start which allowed the mysqld.sock file to be created.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.