Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does anyone have an experience with Ubuntu that is no longer reading discs in the DVD drive? This is my first time Ubuntu does not see the disc :| The disc is fine and works on my other Ubuntu computers.

The drive is there and powered. I can even type in eject in a terminal and the drive will open. Using the command: sudo lshw -C disk I am able to see info about my drive too. Actually BOTH of my internal DVD drives cannot read discs anymore. If the output is not readable below, here is the info in pastebin.

http://pastebin.com/GqqSCTPw

*-cdrom:0               
       description: DVD writer
       product: DVD_RW ND-3500AG
       vendor: _NEC
       physical id: 0.0.0
       bus info: scsi@0:0.0.0
       logical name: /dev/cdrom1
       logical name: /dev/cdrw1
       logical name: /dev/dvd1
       logical name: /dev/dvdrw1
       logical name: /dev/scd0
       logical name: /dev/sr0
       version: 2.1B
       serial: [_NEC    DVD_RW ND-3500AG2.1B06022300BT-LIGGY
       capabilities: removable audio cd-r cd-rw dvd dvd-r
       configuration: ansiversion=5 status=nodisc
  *-cdrom:1
       description: DVD-RAM writer
       product: CDDVDW SH-S222A
       vendor: TSSTcorp
       physical id: 0.1.0
       bus info: scsi@0:0.1.0
       logical name: /dev/cdrom
       logical name: /dev/cdrw
           logical name: /dev/dvd
       logical name: /dev/dvdrw
       logical name: /dev/scd1
       logical name: /dev/sr1
       version: SB01
       capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
       configuration: ansiversion=5 status=nodisc
share|improve this question
1  
Can you mount the DVD manually from the command line, e.g. sudo mount -t auto /dev/dvd /media/dvd (making sure that /media/dvd already exists)? If so, this could be a problem with the desktop automounting configuration. –  OrbWeaver Jul 15 '11 at 9:42
    
It would be odd if this was a hardware problem because both drives broke at the same time. But perhaps there is a problem with the motherboard. If you have a bootable linux (or windows) install CD it would be worth testing it you can still boot. Once you've eliminated hardware you can focus on the ubuntu config. –  Peter Jenkins Nov 24 '12 at 23:12
    
@IHeartUbuntu How did you solve this trouble? –  nazar_art Jul 10 at 16:50

6 Answers 6

Is it one specific DVD or all DVDs?

If it's all DVDs: You should also check the regionset in terminal type, sudo apt-get install regionset and then sudo regionset. And make sure the region code of the drive matches your region code. (This happened to me a couple of times randomly...)

If it's one specific DVD: Have you remembered to install libdvdread4 (if it's an encrypted DVD)?

share|improve this answer
1  
no, any dvd.. not necessarily a movie. in fact i cannot read cd's either. my guess is that there was an update that changed something, because i had to use the Ubuntu CD to install Ubuntu initially :) –  I Heart Ubuntu Jun 6 '11 at 23:52

I had a similar problem with mine not reading any disks and burning disks that were totally corrupted and useless. Turned out the laser in the drive had burnt out and was no good. Got a new drive everything worked fine.

share|improve this answer

Adding a entry in /etc/fstab may solve your issue, I was having issues using programs in wine that would not recognize my cdrom. In your case start by running:

sudo mkdir -v /media/cdrom0 ; sudo mkdir -v /media/cdrom1

This will create the future mount points for your cdrom drives. Then run this command which will edit in the proper lines in your fstab file:

 echo "# cdrom 0" | sudo tee -a /etc/fstab ; echo "/dev/sr0 /media/cdrom/  auto ro,noauto,user,exec 0 0" | sudo tee -a /etc/fstab ; echo "# cdrom 1" | sudo tee -a /etc/fstab ; echo "/dev/sr0 /media/cdrom/ auto ro,noauto,user,exec 0 0" | sudo tee -a /etc/fstab

Then you will want to remount the file systems listed in fstab with this command:

sudo mount -a

Pop in a cd or dvd to see it this corrected the issue. If it did solve the issue there is some problem with automount. This is only a workaround for a bigger problem.

share|improve this answer

According to this post -- http://ubuntuforums.org/showthread.php?t=1950008

Ubuntu 11.10 can not read the drive is set to 'Slave'. Setting it to 'Master' solved the problem.

Quote:

So I have solved this problem. Lots of searching etc led me to pull the DVD / CD drive out of the system and have a look if it was set to 'Slave' or 'Master' via the pins on the rear of the player.

The switch was set to 'Slave', i moved this across to 'Master' replaced the drive in the PC hooking it up again to it's connections and hey presto everything is fine ! Plays DVD's and audio CD's etc no problem.

share|improve this answer
    
I read that thread ... I'm not convinced this is the issue here, and telling someone to start changing their hardware configuration should be a last resort. –  Peter Jenkins Nov 24 '12 at 23:08

I had this problem, though the difference is that I got an error message that said :

mount point /media/cdrom/ does not exist

So instead of directly applying what dginsd says, you might want to try making a directory according to what error message you get, if you do get one. Since mine showed the above, this is what I put in the command line and it solved the problem for me:

sudo mkdir -v /media/cdrom

And you're done. This did it for me. Make sure to do it according to your error message.

share|improve this answer
    
I'm a bit new to this space so please excuse me for making you gnash your teeth on seeing that the code line doesn't show up like its on the other answers and comments. Sorry in advance :) –  Phoenix024 Jan 10 at 5:48
    
To format something as code, indent it with 4 spaces in front. See the editing help –  minerz029 Jan 10 at 5:56

Type in:

sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && 
sudo apt-get --quiet update && 
sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && 
sudo apt-get --quiet update

This did the trick for me.

share|improve this answer
    
You should really explain what these commands do. What are you recommending to install and why? –  Peter Jenkins Nov 24 '12 at 23:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.