Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm converting mp4 videos to webm with the following command:

avconv -i INPUT.mp4 -c:v libvpx -qmin 10 -qmax 42 -maxrate 500k -bufsize 1000k -threads 2 -c:a libvorbis OUTPUT.webm

Am I doing something wrong? Should I use all of these parameters? I just want to make the videos compatible with all the browsers/devices.

The videos are not working on Firefox on most devices and on Chrome in a specific Android device that I have.

EDIT: When i play the embeded videos on firefox, on any android device, it goes straight to the end and doesn't play. It only plays if i click in the progress bar. If i open the videos on firefox without embedding them in a html page, they seem to have a bigger width box outside then, while the video is inside it.

I uploaded a video that i converted. Try it in firefox: https://mega.co.nz/#!cg9FVZJD!CpC6X3NXH8rAVdBiS9ZqqwyITdyPb_qkKAKsvQXRpzI

This is a comparison between the videos, after and before the conversion: ![Image here]: http://i.imgur.com/V2FijCQ.jpg

share|improve this question
1  
Exactly how they don't "work"? –  Braiam May 27 at 23:37
    
All those files are working here. –  bodhi.zazen May 27 at 23:43
    
I uploaded one of the converted videos, check the post and try it on Firefox, on desktop or android device. –  user285943 May 27 at 23:52
    
works fine for me on VLC and Chrome, but not in Firefox, where I have to jump somewhere in the video to get it to play (using <video src="video.webm" controls></video>). Don't forget that Firefox is not compatible with WebM VP9, only VP8. IDK about libvpx, but maybe now it encodes VP9 by default ? (wasnt the case in february 2013, but that was "long ago") –  MrVaykadji May 28 at 0:12
    
Im using firefox to open random VP9 videos around the web and they all seem to work... i don't get why this one isn't –  user285943 May 28 at 0:47

2 Answers 2

I have the same issue, using the same conversion tool. The video plays as normal in Chromium, but not Firefox 30 (Linux) or Aurora 31 (Windows). When I used ffmpeg (of which avconv is a fork) a couple of months back, all worked as expected.

What I have noticed is that on Firefox, the progress bar appears for the video and it shows as if the the video has already been played. Sliding this back to the start and pressing play will display the video, but it appears in the centre of the screen and too small to see the content. If you right click the tiny video and click on full-screen, it will play normally.

The old webm videos made with ffmpeg work fine in the same version of Firefox so it appears that the files created by avconv are different in some way. Perhaps they do not correctly report their dimensions for some reason?

I will try to fiddle around over the weekend and report back.

Regards,

Steve

share|improve this answer
    
Just following up on this, I have since download ffmpeg and converted the same file to webm. That worked in Firefox. I would suggest you try that as a workaround. I will try and distil a bug report out of it later this weekend and report it to the relevant project. Regards, Steve –  SteveM Jun 14 at 8:42

I'm having the same experience, though I note that the WEBM files I'm getting are using VP8, not VP9.

Here's the command line I am using on both an Ubuntu 12.04 and a 14.04 system:

avconv -threads auto -strict experimental -i /tmp/c5858937cc47b4c237e1a6ba0b8ba01220140627-2490-1vwkdcr -y -vcodec libvpx -b 250k -maxrate 250k -bufsize 500k -pix_fmt yuv420p -flags +mv4+aic -threads auto -b:a 128k -strict -2 -s 640x360 /tmp/c5858937cc47b4c237e1a6ba0b8ba01220140627-2490-1vwkdcr20140627-2490-ufj5hv.webm

There are no error messages on either system.

  • On the 12.04 system, the webm video behaves as expected - intial frame of the video shows up in the embedded player, video plays just fine.

  • If I open the file in VLC, it plays just fine.

  • On a 14.04 server using the version of avconv that comes with it, If I embed the file in a web page, the video appears black. Pressing play on the player (VideoJS) just skips to the end.

  • If I drag the VideoJS slider backwards, I can see a frame of the video, but it will not play.

I'm using the same Ruby on Rails app on both systems, the same version of jquery, videojs, and any other javascript libraries.

I'm going to try using a binary from a 12.04 system on the 14.04 system and see if the behavior is any different, will report back here.

share|improve this answer
    
Yeah... not really possible due to being linked against newer versions of libavformat et al. –  mjp Jun 27 at 14:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.