Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just upgraded to 14.04 to try to fix some other issues. Now, something has gone wrong with my graphics.

I have a Thinkpad T530 with Intel and Nvidia graphics cards.

$ inxi -SGx
System:    Host: xyz Kernel: 3.13.0-24-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: N/A Distro: Ubuntu 14.04 trusty
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0 
           Card-2: NVIDIA GF108M [NVS 5400M] bus-ID: 01:00.0 
           X.Org: 1.15.1 drivers: fbdev,vesa,intel,nouveau (unloaded: nvidia) Resolution: 1920x1080@0.0hz 
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

$ glxinfo
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

I'm not sure what I did but now something is wrong with my graphics, as should be visible from the above commands. nvidia-detector says "none" as well.

I used to have bumblebee but then some website said to remove it and now something's clearly wrong. What's the right way to set things up? Should I try to add bumblebee back?

Here's what's installed now:

$ dpkg --get-selections | grep nvidia
nvidia-319                  install
nvidia-331                  install
nvidia-libopencl1-331               install
nvidia-opencl-icd-331               install
nvidia-prime                    install
nvidia-settings                 install
nvidia-settings-319             install
share|improve this question

2 Answers 2

You can install all video drivers with the package xserver-xorg-video-all.

sudo apt-get install linux-headers-generic xserver-xorg-video-all libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
share|improve this answer
1  
There was a build error in one of the kernel modules: ` CC [M] /var/lib/dkms/vboxhost/4.2.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.o /var/lib/dkms/vboxhost/4.2.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.c: In function ‘rtR0MemObjNativeMapUser’: /var/lib/dkms/vboxhost/4.2.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.c:153‌​9:26: error: ‘struct mm_struct’ has no member named ‘numa_next_reset’ pTask->mm->numa_next_reset = jiffies + 0x7fffffffffffffffUL; ^ ...` –  Espressofa May 27 at 14:39
    
Which caused: Error! Bad return status for module build on kernel: 3.13.0-27-generic (x86_64) –  Espressofa May 27 at 14:40
    
Also, glxinfo reports the same thing. –  Espressofa May 27 at 14:45
    
Did you copy the full line? –  Korkel May 27 at 14:48
1  
No, that is not wrong. –  Korkel May 27 at 15:08

Before you proceed with the following please consider removing other nvidia drivers that might conflict.

For the latest proprietary Nvidia driver the following commands may be issued :

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

For Nvidia Optimus technology (Nvidia+Intel) and the benefit of Bumblebee features the following must be issued :

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

A final tip is to remember using optirun command in prefix of the 3D software command

optirun somegame-or-command

You can also test 3D with the following commands

glxspheres 
optirun glxspheres 
share|improve this answer
    
I'll give this a shot. –  Espressofa May 30 at 11:55
    
When I try an optirun command: $ sudo optirun firefox [sudo] password for xyz: [ 526.850214] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13]. [ 526.850286] [ERROR]Aborting because fallback start is disabled. –  Espressofa May 30 at 12:09
    
But this might have fixed some other issues I was having. –  Espressofa May 30 at 12:09
    
Did you purge the older nvidia packages ? "sudo apt-get purge packages" instead of "sudo apt-get remove packages" to remove configuration files? I think you can still reconfigure nvidia anyway with the following command "sudo nvidia-xconfig" See if this fixes your problem. You can also test 3D with the following "glxspheres" and "optirun glxspheres" –  Ahmed Sghaier May 30 at 13:16
    
I don't have nvidia-xconfig, unfortunately. Do you know what package provides that? –  Espressofa May 30 at 16:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.