Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While trying to build a package, I gave the following command in terminal:

cd Downloads/src/
cd unity-5.10.0/
dpkg-buildpackage -rfakeroot -uc -b

Then it gives the output:

dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
dpkg-buildpackage: source package unity
dpkg-buildpackage: source version 5.10.0-0ubuntu6
dpkg-buildpackage: source changed by Didier Roche <didrocks@ubuntu.com>
dpkg-buildpackage: host architecture i386
dpkg-source --before-build unity-5.10.0
dpkg-checkbuilddeps: Unmet build dependencies: libutouch-grail-dev (>= 1.0.20) libutouch-geis-dev (>= 2.0.10)
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)

Then I tried to install the package using:

cd..
sudo dpkg -i *deb

And it gives:

[sudo] password for harshnarang8: 
dpkg: error processing *deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
*deb

What is exactly causing the problem and how to encounter it?

share|improve this question
    
Which version of Ubuntu are you building on? Why are you trying to build unity-5.10 specifically? –  bain May 27 at 15:48
    
I am using 12.04 LTS and Actually i wanted to change the look of the notification bar. So i wanted to change the source. –  newcode May 27 at 15:51
    
Ok you could try a newer Unity, the latest Unity version is 5.20.0 for 12.04 LTS packages.ubuntu.com/precise-updates/unity –  bain May 27 at 15:54
    
I tried installing the packages as you suggested. It works well. –  newcode May 27 at 15:57
add comment

1 Answer 1

up vote 0 down vote accepted
dpkg-checkbuilddeps: Unmet build dependencies: libutouch-grail-dev (>= 1.0.20) libutouch-geis-dev (>= 2.0.10)
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.

libutouch-grail-dev is one of the build dependencies, but you have not installed it. Do:

apt-get build-dep unity

Your second error happens because the package build failed, so you do not have a built package. You can not install a package that you do not have.

share|improve this answer
    
on using the command: 'sudo apt-get build-dep unity' nothing gets downloaded. –  newcode May 27 at 14:53
    
apt-get build-dep unity on a fresh 14.04 system will install 162 packages. Perhaps you already installed them? It looks like you are trying to build an old version of Unity, and it has a bug causing the build dependencies to be incomplete. Build a more recent version of Unity, or satisfy the dependencies manually (apt-get install libutouch-grail-dev libutouch-geis-dev) –  bain May 27 at 15:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.