Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have looked through the community but being new gives me a disadvantage...

I have Ubuntu 14.04LTS installed on a Dell Latitude D830

I went to software updates and enabled the broadcom driver Also enabled the Nvidia driver that was a proprietary driver

I can connect via the ethernet cable, but I have no sign of it detecting anything wireless. I don't have a switch to cut wifi on/off on this laptop.

I have reset both the modem and router. I looked on here and found a few threads talking about "soft blocked" and other options. I followed them in the terminal but had no success.

Any help is appreciated. If you need more information please let me know what to do next.

vinny@Vinnys-PC:~$ lspci -nn | grep 0280
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 01)
share|improve this question

3 Answers 3

I have had the same problem as you, and in the terminal you can enter:

rfkill list

show soft and hard block if it is blocked you can enter:

rfkill unblock wlan0

and then you can in the terminal enter:

lspci

shows the wireless info, and then in the terminal enter:

lsusb wlan0

and if it is down then in the terminal enter:

ifdown wlan0
lsmod wlan0

and it set the wireless to be users, and then you sould scan the port, and in the terminal enter:

nmap -v -iR 10000 -Pn -p port

and then restart the system and it might work fine.

share|improve this answer
    
I did this as well and it is finally working. thanks! –  user_Vinny285679 May 27 at 6:29

Do:

sudo apt-get purge bcmwl-kernel-source
sudo apt-get update
sudo apt-get install linux-firmware-nonfree

Reboot

share|improve this answer
    
thank you this seems to have worked. when I rebooted it got stuck at a screen and something failed tho. I had to manually turn the pc off –  user_Vinny285679 May 27 at 6:27
    
It had nothing to do with the commands I had you run, please accept the answer so everyone can benefit from it. Thanks –  Wild Man May 27 at 10:34
sudo apt-get remove bcmwl-kernel-source
sudo apt-get update
sudo apt-get install firmware-b43-installer b43-fwcutter
sudo reboot

From the ubuntu forums on a thread concerning 12.10, worked well for me on 14.04 while linux-firmware-nonfree (mentioned in another answer) caused same errors as you, only it did not work at all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.