Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The only thing really missing from this install is this issue with the sound. I've searched all over the forums and i found one thing where you get the model and codecs and write them to a file, however, I can't seem to find what my "model" is because none of the postings have anything about Lenovo laptops. Here is the command they all asked for: Code:

cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC269
Codec: Intel G45 DEVIBX

With that info, how do I get the model, and how do I get my speakers to stop playing when headphones are plugged in. Also, if i manually change the output device to headphones itll play just headphones in the sys prefs... so it CAN work, but it doesn't.

I have a Lenovo ThinkPad L512 as well.

Thanks so much to whoever can answer this...

The Ubuntu forums are nearly useless... ive never gotten a correct answer back on that site.

Also, i've filed a bug report and i know it's the ALSA plugin, i don't know how to fix it though.

share|improve this question
    
What are your alsamixers like? Run "alsamixer -c0" (no quotes) in a terminal. –  NightwishFan Sep 25 '10 at 0:03
    
yfrog.com/6coscargodsonubuntu005p -- ? –  Oscar Godson Sep 26 '10 at 19:59
    
All you can really do is wait for the bug to be fixed. I'm assuming you either included alsa-info.sh output or used ubuntu-bug linux or ubuntu-bug -s audio to include debugging info –  maco Sep 28 '10 at 0:44
    
The mixer channel to do so is usually called front. It might be pulse restricting it. EDIT: I see you have no front. You can use the M key to mute a channel. Try playing with the mixers. –  NightwishFan Sep 28 '10 at 0:52
    
This question appears to be abandonded, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. –  Jorge Castro Dec 5 '11 at 18:29
add comment

closed as too localized by Luis Alvarado Mar 14 '13 at 17:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

This is a workaround:

Go to "sound preferences" and select the "Output" tab. There select "Analog Output" in the connector option.

share|improve this answer
    
No sound comes out at all when I do that in either headphones or speakers. –  Oscar Godson Sep 26 '10 at 19:56
    
Check alsamixer after you do that, the channel might have just been muted. –  NightwishFan Sep 28 '10 at 0:54
    
Yeah, it was muted, but if i unmute it then it gets unmuted whether the headphones are plugged in or not. :( –  Oscar Godson Sep 28 '10 at 21:46
add comment

Where is your LP bug? I don't see it listed anywhere.

I wonder if we're setting a quirk incorrectly in /sbin/alsa-utils. That gets fired off on hotplug events.

As a quick test, you could comment out this line:

    exec /sbin/alsa-utils start $N

which can be found in /lib/udev/alsa-utils. Commenting it out will prevent the hotplug script from firing. Reboot after you comment it out, and see if that improves behavior any.

share|improve this answer
    
That didn't do anything. I think the issue is more that it's acting as if it WERE commented out. When I plug it in no event fires at all to change anything. –  Oscar Godson Oct 1 '10 at 18:14
    
What is the LP bug with all your information? –  achiang Oct 1 '10 at 19:32
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.