Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 11.04 x86 server.

I ran sudo apt-get install vsftpd and that was successful. But I cannot find the vsftpd.conf file anywhere. I thought it was supposed to be in /etc/vsftpd.conf.

share|improve this question
1  
try this command locate vsftpd.conf –  nitstorm Jun 6 '11 at 13:31
1  
It's supposed to be there. What is the output of debsums -a vsftpd? –  ændrük Jun 6 '11 at 13:32
    
That finds me /etc/init/vsftpd.conf, which is the startup script for vsftpd. Should I just find the default conf file and put it in there myself? –  Nik Jun 6 '11 at 13:33
1  
debsums says: debsums: missing file /etc/vsftpd.conf (from vsftpd package) –  Nik Jun 6 '11 at 13:34
1  
@Nik: it's not a clean solution and would only work if someone posted the configuration file. Could you remove (or rename) the configuration file (after stopping vsftpd) and try my solution? That is the way the system is supposed to work. –  Lekensteyn Jun 6 '11 at 16:08
show 1 more comment

5 Answers

You've a weird issue, try clearing you cache, update your repository information and install it again:

sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall vsftpd

If this did not work, purge vsftpd (remove it including its configuration files) and reinstall it:

sudo apt-get purge vsftpd
sudo apt-get install vsftpd
share|improve this answer
add comment

It sounds like the installation didn't complete successfully. The quickest solution is probably going to be to reinstall vsftpd:

sudo apt-get install --reinstall vsftpd
share|improve this answer
    
That hasn't made the conf file show up. –  Nik Jun 6 '11 at 13:37
2  
Just installed it and it's there. Here it is: paste.ubuntu.com/619932 –  htorque Jun 6 '11 at 13:42
    
I appreciate the copy of the file. –  Nik Jun 6 '11 at 13:46
add comment

Try:

cat /etc/vsftpd/vsftpd.conf

That is where it is located for me.

share|improve this answer
add comment

I had this problem too. When I observed the installation log carefully, it turned out that the installation was stopping before re-installing the directory "srv/ftp". I deleted the directory ftp from /srv so that /srv was empty. Then I reinstalled and had my original vsftpd.conf script replaced in /etc/vsftpd.conf.

share|improve this answer
    
Uh. Be sure to inspect whether you want to delete /srv, as it may contain files you want to keep. –  Olli Mar 13 at 9:46
add comment

Try

sudo dpkg-reconfigure vsftpd

This will affect package's configuration and rerun some scripts designed for package proper operation.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.