Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo ThinkPad edge e531 laptop that dual boots windows 7 and Ubuntu 14.04. Prior to upgrading to 14.04 I was using bumblebee in order to utilize my nvidia gpu (Nvidia GeForce 740M). In 14.04 I read somewhere that it was better to use prime and switch easily between the two graphic cards at any time.

So I tried installing nvidia 331, 337 and all other versions between 331 and 337 that automatically came with prime installed, but I encountered the following problem:

Once the nvidia driver is installed, the laptop starts using the nvidia card exclusively and when I switch back to my Intel card I can no longer open nvidia settings and I can no longer switch back to my nvidia card. This is what I get when I try to launch nvidia settings from the terminal:

** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes
Segmentation fault (core dumped)

I tried everything (installed prime indicator, tried with different version of nvidia driver), but to no avail. Any help will be greatly appreciated! Thank you.

share|improve this question

1 Answer 1

I have been able to find a solution (using the terminal to move between graphic cards, having a GeForce 840M and Ubuntu 14.04).

First of all, I had broken many things in the system, so I decided to reinstall Ubuntu 14.04 again (some things were not fixed after removing nvidia packages... so I decided to start from scratch). After having Ubuntu 14.04 completely new, I have added the following repository:

sudo add-apt-repository ppa:xorg-edgers/ppa

Then I did the classical apt-get update and apt-get upgrade, and after that, I installed only these 2 packages:

sudo apt-get install nvidia-common
sudo apt-get install nvidia-331

The driver for my 840M GPU should be the 337, but I read that probably 331 works in a better way.

So I rebooted and everything seemed to be right. Then, by running

prime-select query

I saw that it was using nvidia. And nvidia-settings opened correctly. Then I chose from the nvidia-settings to move to Intel. I logged out and when I came back, I was working with intel (check it with prime-select query).

And at this point, nvidia-settings stops working and is not able to open. But if I run in a terminal

sudo prime-select nvidia

and then I log out, the new session start under nvidia GPU and nvidia-settings is able to open again.

In conclusion, after doing that, now I move from one GPU to the other by typing

sudo prime-select nvidia

or

sudo prime-select intel

and logging out after it. And the nvidia-settings only opens when I'm working under the nvidia GPU.

I hope this will be useful for you... I've tried 331 drivers before, but it had't work. I think for me the important point was to reinstall Ubuntu and to install 331 drivers at the begining.

In addition, I have to say that the first time I move from the Intel to Nvidia, X crashed and asked me about reconfiguring it. I said ok, I rebooted and from that point now I move from intel to nvidia (using the terminal) without problems, but probably you won't have this X crash...

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.