Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't install xojo. When I click install in the software center it's not progressing. In the terminal it's stuck in :

gichan02@gichan02-Latitude-D520:~$ sudo apt-get install xojo
[sudo] password for gichan02: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
xojo-bin
The following NEW packages will be installed:
 xojo xojo-bin
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 209 MB/209 MB of archives.
After this operation, 596 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
0% [Working]

then after waiting for an hour for progress it says:

Failed to fetch https://private-ppa.launchpad.net/commercial-ppa-uploaders/xojo/ubuntu/pool/main/x/xojo/xojo-bin_2013.41-0ubuntu1_i386.deb Could not resolve host: private-ppa.launchpad.net

So I added apt repository for 'private-ppa':

deb https://ging-giana:D69GwG16ZQKz2Rkb4C0Q@private-ppa.launchpad.net/commercial-ppa-uploaders/xojo/ubuntu trusty main

Then when I try 'apt-get update':

GPG error: https://private-ppa.launchpad.net trusty Release: The following signatures were invalid: NODATA 2

Then I noticed something the Software Sources:Other software TAB:

Added by software-center; credentials stored in /etc/apt/auth.conf
https://private-ppa.launchpad.net/commercial-ppa-uploaders/xojo/ubuntu

So i go to the '/etc/apt/auth.conf' ,but It cannot be opened and it is not a keyserver.
So i uncheck:

Added by software-center; credentials stored in /etc/apt/auth.conf
https://private-ppa.launchpad.net/commercial-ppa-uploaders/xojo/ubuntu

GPG error was gone.
But then again I found myself at the beginning of the problem.STUCK at '0% [Working]'.

'Xojo' is the only application that I can't install.Any explanation why is it like that?

share|improve this question
1  
Try from command line and see if it throws errors (if so: add them to your question by editing) (open a terminal and then sudo apt-get install xojo) –  Rinzwind May 26 at 14:14
    
@Rinzwind terminal stack at "0% [Working]" –  Gichan May 26 at 14:21
    
Are you behind a proxy server? If yes, have you added your proxy parameters in System settings-> Network -> Network Proxy? –  i08in May 27 at 7:04
    
@Jobin No.I connect directly. –  Gichan May 27 at 7:11
    
Try ping private-ppa.launchpad.net –  bain May 27 at 10:20

1 Answer 1

up vote 0 down vote accepted

Thank you @bain.

I download .deb file in launhpad instead of downloading it in Software center or terminal. I go to the 'My profile' then click ' View your private PPA subscriptions' so i can view the private PPA permission.Then click the link in the box and download the .deb file for ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.