Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I've got Java working on Firefox in Ubuntu 11.04 (Natty Narwhal), but using the same page on Chromium tells me Java cannot be found.

How can I enable Java on Chromium in my Ubuntu 11.04?

share|improve this question

marked as duplicate by Eric Carvalho, Videonauth, MadMike, saji89, Wild Man Jul 12 at 0:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Is Ubuntu restricted extras Installed ? – Binarylife Jun 6 '11 at 12:10
1  
Installed and still no luck. – mrobertran Jun 6 '11 at 12:18
    
Can you try if it's not the specific page you are trying to see is causing the problem? Try other java pages to see if they work. – 719016 Jun 6 '11 at 12:39

The first thing to do is to install Java:

$ sudo apt-get update
$ sudo apt-get install openjdk-7-jre icedtea-7-plugin

Restart chromium-browser and then use about:plugins to check if it's enabled.

share|improve this answer
2  
No need for openjdk, icedtea-*-plugin is enough – DiAlex Feb 8 '14 at 16:12
2  
I have both of those but don't see an option in about:plugins to enable it. – isomorphismes Sep 3 '14 at 19:23
  • Go to : about:plugins
  • Under location: you should see enable (if it is disabled).

Java Plugin

This happened with me at first.

Also, see: Do I have Java? If it takes too long , it means that there isn't java installed or something went wrong during installation.

share|improve this answer

According to this

You can't. You would have to recompile Chromium and edit the line that disallows NPAPI.

share|improve this answer

You get the IcedTea-web Java browser plugin by installing the icedtea-plugin package.

You can quickly do this from the command line running:

sudo apt-get update && sudo apt-get install icedtea-plugin
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.