Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need some assistance, I have 2 laptops, a Toshiba and a DELL XPS M1330, the problem is using my DELL laptop, when I use the HDMI cable to use the TV as monitor the display works fine however the sound only work in the laptop speakers I can't use the TV speakers.

When I go to "Sound" settings to select the HDMI in the "Play sound through", I can't select the HDMI because it never show up. I can only see, "headphones and speakers".

So as a summary the, display works but the sound it doesn't in the TV. Any ideas?

share|improve this question
    
This sound completely foolish but when you check sound options with Dell laptop is HDMI cable attached at both ends in respective ports and display is on? –  The Dentist Feb 23 at 10:27

4 Answers 4

To get HDMI audio working on Ubuntu, please download the deb file for your version of Ubuntu from this link:

https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/ and install it via cli or the software centre.

  1. For older packages go to page: https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+packages
  2. Then force reload alsa using the following command : sudo alsa force-reload
  3. After that, select HDMI from the sound menu as shown below (for me this option appeared only after installing the above mentioned package)

    enter image description here

Please note HDMI audio function tested on Intel graphics only on a Lenovo Flex2 14 laptop

share|improve this answer
    
No luck when trying this on ubuntu 15.04... –  cboettig May 28 at 4:43

It seems that your laptop has dual graphics which may need you to install the Nvidia binary driver and Bumblebee from this guide: https://wiki.ubuntu.com/Bumblebee

share|improve this answer
    
thanks for the help, I tried the steps mentioned in the link however the issue remains. –  Oso May 26 '14 at 16:07
    
Not sure why you suggest installing NVIDIA binaries -- nothing in the Oso's question seems to suggest this is an NVIDIA card. I believe the Dell he describes, the XPS M1330, has integrated Intel GMA graphics (cnet.com/products/dell-xps-m1330/specs) –  cboettig May 28 at 4:47

Try the following:
Reinstall Alsa and Pulse Audio

Open an Terminal (CTRL+ATL+T).

Try to reinstall pulse audio and Alsa, open terminal and enter the following commands:

Purge Alsa and Pulse audio using the command:

sudo apt-get remove --purge alsa-base pulseaudio

Now install again Alsa and Pulse Audio:

sudo apt-get install alsa-base pulseaudio

Then, reload Alsa:

sudo alsa force-reload

Done, if it is not working try the following:

 sudo add-apt-repository ppa:ubuntu-audio-dev
 sudo apt-get update
 sudo apt-get dist-upgrade

Pleas note, that driver is NOT updated for Ubuntu 14.04 yet.

share|improve this answer
    
I tried your solution but increased problems than solving it. –  Fooo Oct 3 '14 at 6:42

I follow the below workaround whenever I connect laptop to a TV:

  1. Connect HDMI cable to TV and switch on the TV.
  2. Run the below command on a console (It worked without sudo)

    pulseaudio -k
    
  3. Open Sound settings, you should see "HDMI/Display Port" entry under Output tab.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.