Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In older versions of Ubuntu, /usr/share/dbus-1/services/org.freedesktop.Notifications.service could be edited to change the default notification daemon.

However changing this file no longer affects the default notification daemon in the newer version. Any ideas on how to change the default notification daemon?

share|improve this question
    
You sure about file is exist and/or not was renamed? –  swift Jun 15 at 4:32
    
sorry stupid question ... better, say please what desktop manager and desktop environment you use? –  swift Jun 15 at 4:52
    
@swift, the file was not renamed or moved. The problem is that modifying this file no longer changes the notification daemon. I use the default Unity desktop environment. –  Alex Jun 15 at 8:39
    
there nice answer by @Magpie: Unity notifications messed up after installing Gnome –  swift Jun 15 at 10:34
    
Ok I got it, Unity, however GDM or LightDM ? –  swift Jun 16 at 8:48

2 Answers 2

up vote 1 down vote accepted
+50

It seems there is no priority or a single setting point to set which freedesktop notification daemon to run. I got such problem with XFCE installed on Ubuntu 14.04.

Unity notification launch xfce4-notifyd as it was the default.

  • Check for available notification services, example:

    $ grep -r org.freedesktop.Notifications /usr/share/dbus-1/services/
    /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service:Name=org.freedesktop.Notifications
    /usr/share/dbus-1/services/org.freedesktop.Notifications.service:Name=org.freedesktop.Notifications
    
  • Disable non needed ones, leave only the one you want:

    sudo mv /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service.disable
    
    pkill xfce4-notifyd
    
  • Check

    notify-send test
    

Unity notification style back (notify-osd)

Another way, Unity does not launch any default notifications daemon. So you can add the one you like to Upstart Application. See How do I start applications automatically on login?. I think it's better because it does not affect other desktop session that relays on the service file to start their notifications daemon.

Helpful Reference:

share|improve this answer

To begin need to say that behavior is reason to decide it is incorrect work of NotifyOSD with Compiz or Metacity what depends on your preferences. It can be also result of change desktop manager (alike GDM). So better solution for you will be better details what you want to do and where. "Where" is where your NotifyOSD server have works.

So if your details is Unity solutions is:

killall notify-osd
notify-osd

or if above trial was unsuccessful so you can try resolve most common environment:

sudo apt-get build-deps unity

Let's to find answer together.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.