Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The boot menu does not show up even though /etc/default/grub contains:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Yes, I did update-grub. Holding the shift key did not help either.

share|improve this question
    
Edit your question and add the output of sudo grub-mkconfig –  Braiam May 25 at 23:39

1 Answer 1

up vote 0 down vote accepted

An easy fix for your problem is to install grub customizer. Not only can you easily customize grub with it, you can customize burg too which is what I'm using. You can mess with the settings until you fix it. It's pretty straight foward. (Type or copy these onto the terminal then press enter after each line.)

    sudo add-apt-repository ppa:danielrichter2007/grub-customizer
    sudo apt-get update
    sudo apt-get install grub-customizer
share|improve this answer
    
This works fine, thanks! Still, I don't understand why, in 14.04, the boot menu is not visible by default. And how I could have repaired that without this graphical interface. –  user1523314 May 26 at 9:47
    
Trying to find out, I found that grub-customizer can restore the old situation with the Revert button. However: it does not restore /boot/grub/grub.cfg if you only change (under General settings->visibility->Show menu) the visibility of the menu. –  user1523314 May 26 at 10:58
    
When you press the save button, it should run an (sudo) update-grub similar command after making your changes. That should reload grub.cfg –  Tatakai Wasumi May 26 at 17:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.