Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Getting the following error message while installing Ease even the required packages are there. Please see below for full details. Please let me know what went wrong. ...

configure: error: Package requirements ( clutter-gst-1.0 clutter-gtk-0.10 >= 0.10 gee-1.0 gmodule-2.0 json-glib-1.0 >= 0.7.6 libarchive poppler-glib rest-0.6  rest-extras-0.6 unique-1.0) were not met:

No package 'clutter-gst-1.0' found

No package 'gee-1.0' found

No package 'poppler-glib' found

No package 'rest-0.6' found

No package 'rest-extras-0.6' found

No package 'unique-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variables EASE_CFLAGS and EASE_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

-------------------------------------------------------------------

 $ apt-cache policy clutter-gst-1.0 

gir1.2-clutter-gst-1.0:
  Installed: (none)
  Candidate: 1.3.6-1
  Version table:
     1.3.6-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
libclutter-gst-1.0-0:
  Installed: 1.3.6-1
  Candidate: 1.3.6-1
  Version table:
 *** 1.3.6-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status
     1.2.0-0ppa1natty0 0
        500 http://ppa.launchpad.net/natesm/ease/ubuntu/ natty/main i386 Packages
libclutter-gst-1.0-dbg:
  Installed: (none)
  Candidate: 1.3.6-1
  Version table:
     1.3.6-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
     1.2.0-0ppa1natty0 0
        500 http://ppa.launchpad.net/natesm/ease/ubuntu/ natty/main i386 Packages
libclutter-gst-1.0-dev:
  Installed: (none)
  Candidate: 1.2.0-0ppa1natty0
  Version table:
     1.2.0-0ppa1natty0 
        500 http://ppa.launchpad.net/natesm/ease/ubuntu/ natty/main i386 Packages
share|improve this question
    
i'm getting the exact same message, although the packages are installed. is there a natty compatible ppa maintained by the ease project folks? –  user21199 Jul 6 '11 at 16:48

1 Answer 1

up vote 2 down vote accepted

You need to install the *-dev packages. These contain the headers and other files that are required by the source files you are trying to compile.

Also please note Ease does not seem to be under active development (I emailed the author and never got a reply either).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.