Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I love Unity but its performance is slow and it always lags when I multi task. I have 512 MB of RAM. Please help me, I want to do my work smoothly with Unity.

share|improve this question
1  
The problem is your RAM. You will have to switch to Ubuntu classic, but I doubt that you'd be able to run anything good anyway with the remaining 256 mb of RAM, because the last time I checked Ubuntu normally uses around 256 mb of RAM. –  nickguletskii Jun 6 '11 at 6:42
7  
Current Ubuntu's system requirement is 1 GB RAM. so it's natural you're experiencing lag. Either switch back to GNOME Classic, use Unity 2D or try lighter DE a la Xubuntu, Lubuntu. –  Oxwivi Jun 6 '11 at 7:17
    
It seem like it's not going to work "smoothly" for you. You will need to move to an earlier version of Ubuntu or install XFCE ! –  user36942 Dec 8 '11 at 2:59
    
It's not only about the RAM, which CPU are you using ?? P4 ?? Believe it or not the CPU is the main culprit when it comes to lagging. I own a C2D E4500 with 2 gigs of DDR2 Ram. After 3 years once the core temp of my CPU started exceeding 75, I noticed subtle lag on Ubuntu. –  funkymonk Dec 8 '11 at 6:08
1  
I have 8 GB of DDR3 ram and a i5 Intel i5-2410M CPU @ 2.30GHz / 2.9 GHz Turbo and unity behaves exactly as described above: Slow and laggy while multi tasking... –  n3rd Dec 8 '11 at 7:09
show 1 more comment

1 Answer 1

Here are your best options

  • Upgrade your RAM!

    The more RAM you have the more Ubuntu can cache and the smoother your system will feel. Also, the offical requirements state that you should have at least 1 GB of RAM.

  • Use the classic desktop

    You can switch to the classic desktop very easily. Just go to the shut-down menu in the top–right corner, and click "System settings". There you can change your default desktop environment.

If you can't upgrade your RAM or use the classic desktop you can always tweak your system. If you open the System Monitor you can see what programs use a lot of RAM, try to use others or try not to open all the programs you need at the same time.

If you have classic desktop

If you have some heavy themes or other effects you can turn those down. just go to System → Preferences → Appearance (If you have a classic desktop.)

If you have unity

Just click on the power button in your right corner and select system settings in there you can select Appearance.

share|improve this answer
1  
Also, if it doesn't have to be unity: There are official Ubuntu derivats, that are less hardware hungry. Those include Lubuntu and Xubuntu. –  con-f-use Jun 6 '11 at 7:57
    
yes but he wants to use unity –  Alvar Jun 6 '11 at 7:59
2  
I know. Note the "if" in my comment. Just wanted to encourage him to try something different. Not all hardware is upgradable. 512MB almost sounds like P4. –  con-f-use Jun 6 '11 at 8:09
    
I found zeitgeist eats a lot of memory.. What will happen if I kill the zeitgeist process?? –  otto Jun 6 '11 at 9:03
    
packages.ubuntu.com/en/maverick/zeitgeist I don't know actually. but nothing might happen (guess). –  Alvar Jun 6 '11 at 9:08
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.