Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my network uses the wireless router that came with the cable company. It is not the greatest router but is my only option at this time. I recently received a PlayStation 4 as a gift, and unfortunately the wireless chip in my PS4 only gets along with the wireless chip in my router if Wireless N is turned off, (this information discovered by communications with other people having the same problem.) Unfortunately, the software my cable company has on the router does not allow me to disable the Wireless N.

The PS4 shares a desk with my computer, so I plugged the PS4 into my computer's ethernet port, selected "Shared to other computers" in the wired connection in Network Manager (running Kubuntu 14.04) and everything worked perfectly. The PS4 is assigned address 10.42.0.29 on network 10.42.0.0/255.255.255.0; my computer is 10.0.0.9 on the wireless network which is 10.0.0.0/255.255.255.0 . (I haven't done much networking setup work for almost 20 years so pardon me please if my terminology is a little off.) The PS4 is not visible to other computers on my network, but that didn't seem a problem and everything worked fine so I was happy.

Then yesterday I attempted to connect the PlayStation App on my tablet with the PS4; unfortunately my tablet is obviously on the wireless network and therefore could not see the PS4. It's a little embarrassing as 20 years ago I was setting up Linux routers as part of my job; but I guess it's not like riding a bike because as I read various networking pages on the internet it's all completely unfamiliar. All the pages I've been able to find (and understand) do not bother with trying to make the wired device visible to devices on the wireless network. My first impulse was to try changing the netmask of the wireless network to 255.0.0.0 just to see if it work work; but the junk router only offers 255.255.255.0 and 255.255.0.0 as options. I then tried playing around with setting up a bridge interface, but I only succeeded in knocking my computer off the wireless network completely.

Anyhow, is there any way to make it so that the PS4 appears to the network as though it were a device on the wireless network, or at least has an IP address that is visible from the wireless network?

If it helps, this is the output of ifconfig:

eth0  Link encap:Ethernet  HWaddr 00:21:9b:03:3f:ad  
      inet addr:10.42.0.1  Bcast:10.42.0.255  Mask:255.255.255.0
      inet6 addr: fe80::221:9bff:fe03:3fad/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:4666 errors:0 dropped:0 overruns:0 frame:0
      TX packets:4482 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:700066 (700.0 KB)  TX bytes:3927639 (3.9 MB)
      Interrupt:20 Memory:fdfc0000-fdfe0000 

lo    Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:2211 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2211 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:212468 (212.4 KB)  TX bytes:212468 (212.4 KB)

wlan0 Link encap:Ethernet  HWaddr ec:1a:59:b5:51:42  
      inet addr:10.0.0.9  Bcast:10.0.0.255  Mask:255.255.255.0
      inet6 addr: 2601:2:2680:1bb:11ba:3440:ceaa:3d79/64 Scope:Global
      inet6 addr: 2601:2:2680:1bb:ee1a:59ff:feb5:5142/64 Scope:Global
      inet6 addr: fe80::ee1a:59ff:feb5:5142/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:12042 errors:0 dropped:2147 overruns:0 frame:0
      TX packets:11932 errors:0 dropped:3 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:6930538 (6.9 MB)  TX bytes:2400091 (2.4 MB)
share|improve this question
    
I broke down and bought another router that doesn't have the Comcast router problems and everything is now working fine now; however I would still be interested to know the answer to this problem. –  HarryFromMarydelDE May 31 at 4:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.