Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am aware that the way to change user picture, is creating a .face file on /home... The thing is, this only works when one checks the users and groups on System directory... When it's time to login, nothing is displayed, but the default "faceless" icon... Why is this?

I am using Xubuntu 11.04

share|improve this question
add comment

5 Answers 5

up vote 13 down vote accepted

enter image description here

For Xubuntu versions before 11.10

Create a 96x96 jpg (JPEG) and renamed it as ~/.face.

For Xubuntu versions 11.10 and above

Create a 96x72 png (PNG) and renamed it as ~/.face.

Log-out to see your masterpiece.

how to

The in-built image editor in Xubuntu is Gimp.

Load the image in Gimp and crop the image to approximately 96x96 or 96x72 pixels depending upon your xubuntu version as described above.

Then fine-tune your image via Image - Scale Image...

enter image description here

Break the scale link as shown and enter the pixel size 96 x 96 or 96 x 72 as appropriate. Complete the scale by clicking the Scale button

Save the file. If necessary save the file type when saving (jpg or png).

share|improve this answer
1  
My .face suddenly started showing after upgrading to Raring, but there's still no GUI for changing it in Xubuntu. If there's no GUI for changing it, it really shouldn't be shown (I can imagine less technical users being upset by having some photo there which they cannot change!) –  unhammer May 2 '13 at 9:18
add comment

In Xubuntu 13.10, I believe any square PNG ~/.face file will work. Even transparent ones!

A rectangular image will be squashed, so only use square. Go to switch user screen to test it while editing.

share|improve this answer
add comment

Xubuntu 13.04, created a 64x64 JPEG file, placed it as $HOME/.face -- it works immediately even before logoff (as you can see in Settings-Users and Groups)

share|improve this answer
add comment

96x96 works in 13.04 Xubuntu, at least it does for me. For some reason, I used to have the blank two figure icon in the Login window, then one day after an update, I just had a square with a red X in it. I added the 96x96 .face picture in $home and now have a nice Santa Fe engine at login now.

share|improve this answer
add comment

Application->System->Administration->About Me

Click on the picture-less icon next to your Name and change it to whatever pic you'd like :)

share|improve this answer
    
That option is not available in Xubuntu... –  Gibarian Jun 8 '11 at 12:35
add comment

protected by Community Jan 11 at 15:24

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.