Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

System info:

$ lspci

01:00.0 VGA compatible controller: NVIDIA Corporation NV44 [GeForce 6500] (rev a1)

$ free -m

             total       used       free     shared    buffers     cached
Mem:          7940       7646        294         49        168       3908
-/+ buffers/cache:       3568       4372
Swap:         8143          0       8143

cpu:

vendor_id   : GenuineIntel
cpu family  : 6
model       : 42
model name  : Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
stepping    : 7
microcode   : 0x25
cpu MHz     : 1600.000
cache size  : 8192 KB

$ sudo lshw -short

H/W path        Device      Class          Description
======================================================
                            system         System Product Name (SKU)
/0                          bus            P8H77-M LE
/0/0                        memory         64KiB BIOS
/0/4                        processor      Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
/0/4/5                      memory         32KiB L1 cache
/0/4/6                      memory         256KiB L2 cache
/0/4/7                      memory         8MiB L3 cache
/0/1                        memory         
/0/1/0                      memory         4GiB DIMM DDR3 Synchronous 1333 MHz (0,8 ns)
/0/58                       memory         System Memory
/0/58/0                     memory         4GiB DIMM DDR3 Synchronous 1333 MHz (0,8 ns)
/0/2                        memory         
/0/3                        memory         
/0/100                      bridge         2nd Generation Core Processor Family DRAM Controller
/0/100/1                    bridge         Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
/0/100/1/0                  display        NV44 [GeForce 6500]
/0/100/14                   bus            7 Series/C210 Series Chipset Family USB xHCI Host Controller
/0/100/16                   communication  7 Series/C210 Series Chipset Family MEI Controller #1
/0/100/1a                   bus            7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2
/0/100/1b                   multimedia     7 Series/C210 Series Chipset Family High Definition Audio Controller
/0/100/1c                   bridge         7 Series/C210 Series Chipset Family PCI Express Root Port 1
/0/100/1c.5                 bridge         7 Series/C210 Series Chipset Family PCI Express Root Port 6
/0/100/1c.5/0   eth0        network        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/1c.6                 bridge         82801 PCI Bridge
/0/100/1c.6/0               bridge         ASM1083/1085 PCIe to PCI Bridge
/0/100/1d                   bus            7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1
/0/100/1f                   bridge         H77 Express Chipset LPC Controller
/0/100/1f.2                 storage        7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode]
/0/100/1f.3                 bus            7 Series/C210 Series Chipset Family SMBus Controller
/0/5            scsi0       storage        
/0/5/0.0.0      /dev/sda    disk           500GB WDC WD5000AAKX-0
/0/5/0.0.0/1    /dev/sda1   volume         243MiB Linux filesystem partition
/0/5/0.0.0/2    /dev/sda2   volume         465GiB Extended partition
/0/5/0.0.0/2/5  /dev/sda5   volume         465GiB Linux LVM Physical Volume partition
/0/6            scsi4       storage        
/0/6/0.0.0      /dev/cdrom  disk           CDDVDW SH-222BB
/1                          power          To Be Filled By O.E.M.

Installed nvidia-304 proprietary driver.

The system sometimes getting extremely slow especially performing desktop video effects (all those fade-ins and fade-outs, blurs, etc.)

Previously I had Ubuntu 10.04 and I didn't have any issues with performance.

Is this due to poor video card which is scored just 68 at glmark2 test? What can I do to improve overall performance?

share|improve this question

2 Answers 2

With NVIDIA, your only choice is to either use the proprietary drivers or live with horrible performance. Try installing nvidia-current.

share|improve this answer
    
nvidia-304 proprietary driver was already installed, added to my question –  Nemoden May 25 at 9:36
up vote 0 down vote accepted

Apparently nvidia drivers are written clumsy, after removing nvidia graphics card and staying with built-in one graphics performance improved drastically.

Might help somebody having the same issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.