Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried a lot of methods but cant get this done. I am trying to install rvm on 12.04 ubuntu. There has been many problems in past like this and I have referred as much as I can and still nothing is working for me. Even wirting sudo in front of these doesnt work. What I tried are the following:

  1. \curl -L https://get.rvm.io | bash -s stable --ruby

  2. curl -L get.rvm.io | bash -s stable

  3. curl -L raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer | bash -s stable

I am able to ping each of them though.

Everytime I get the this error: couldn't connect to host OR network is unreachable

it looks like this:

ubuntu@ubuntu:~$ \curl -L https://get.rvm.io | bash -s stable --ruby
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (7) couldn't connect to host

I already tried the solution proposed in Unable to install RVM using curl

I am using NAT adapter for internet and wired connection. I do not have any proxies enabled and all my firewalls are disabled in my hosting OS which is windows.

My proxy settings for ubuntu are set to none

But still I am not able to get this done.

Can somebody tell me what could be the problem and how to fix it. Is it something to do with guest additions because i don't have that yet.

share|improve this question

2 Answers 2

I think you are not able to reach get.rvm.io. You could try running curl in verbose mode and expect some similar output.

Look for Connected to string. If this is not visible and the command is stuck at About to connect() string, you can be assured you have a connectivity problem from your VM.

$ curl -Iv get.rvm.io * Rebuilt URL to: get.rvm.io/ * Adding handle: conn: 0x16fef90 * Adding handle: send: 0 * Adding handle: recv: 0 * Curl_addHandleToPipeline: length: 1 * - Conn 0 (0x16fef90) send_pipe: 1, recv_pipe: 0 * About to connect() to get.rvm.io port 80 (#0) * Trying 97.107.133.48... Connected to get.rvm.io (97.107.133.48) port 80 (#0)

HEAD / HTTP/1.1 User-Agent: curl/7.32.0 Host: get.rvm.io Accept: /

< HTTP/1.1 301 Moved Permanently HTTP/1.1 301 Moved Permanently * Server nginx/1.6.0 is not blacklisted < Server: nginx/1.6.0 Server: nginx/1.6.0 < Date: Sun, 25 May 2014 07:48:40 GMT Date: Sun, 25 May 2014 07:48:40 GMT < Content-Type: text/html Content-Type: text/html < Content-Length: 184 Content-Length: 184 < Connection: keep-alive Connection: keep-alive < Location: https://raw.githubusercontent.com/wayneeseguin/rvm/master/binscripts/rvm-installer Location: https://raw.githubusercontent.com/wayneeseguin/rvm/master/binscripts/rvm-installer

  • Connection #0 to host get.rvm.io left intact
share|improve this answer
    
i got the same error with this too. –  RoR May 25 at 8:01
    
Could you be more specific about the error ? –  Garfield Carneiro May 25 at 8:02
    
now i am not able to ping the address as well –  RoR May 25 at 8:02
    
connection timeout –  RoR May 25 at 8:02
    
network is unreachable then it shows "success" and "couldnot connect to host" –  RoR May 25 at 8:04

RVM can be installed in ubuntu with the repository ppa:rvm/ppa. You dont need to implement difficult compilation methods.

sudo add-apt-repository ppa:rvm/ppa

sudo apt-get update

sudo apt-get install smplayer
share|improve this answer
    
is this for installing ruby? –  RoR May 25 at 8:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.