Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently changed my DE from Unity to XFCE. I really enjoyed it, but the power manager doesn't work. When I try to open it from the settings menu, I get the following error:

Unable to connect to Xfce Power Manager

Did not receive a reply. Possible causes include: 
the remote application did not send a reply, the message bus security policy
blocked the reply, the reply timeout expired, or the network connection was

When I try to run it from the command line, it simply does nothing. I found some other solutions where people said to try running xfce4-power-manager --no-daemon (here: xubuntu 13.10 xfce4-power-manager not working), but then I get the following messages:

(xfce4-power-manager:23973): xfce4-power-manager-WARNING **: could not map keysym 1008ffa8 to keycode

(xfce4-power-manager:23973): xfce4-power-manager-WARNING **: 'CheckAuthorization' failed with Action is not registered

And then the shell halts until I hit ctrl+c.

Then I read that this is a known bug and the best solution was to downgrade to a previous version of the power manager. I tried using aptitude for this, but it complained that every version I wanted did not exist, even if I was taking the version numbers from the xfce4-power-manager repository. The next thing I tried was to download the package and install it myself. But when I tried to configure, the script told me some libraries were missing, even though they are installed:

*** The required package libxfconf-0 was not found on your system.
*** Please install libxfconf-0 (atleast version 4.6.0) or adjust 
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

I was told that library is already pre-installed in Ubuntu.

Then I tried using the gnome-power-manager. Even though it is installed, when I try to run it from the command line, it says there is no such program. And it would also not appear in the XFCE settings menu, which I would like.

share|improve this question

Updating instructions for Xubuntu 14.04.1

First remove the old launcher
sudo rm /etc/xdg/autostart/xfce4-power-manager.desktop

Then create a new one....
Settings Manager / System / Session and Startup
Choose tab Application Autostart

At the bottom click Add and enter the following:

Name: Xfce Power Manager (for example your name)
Description: Power manager startup
New command: xfce4-power-manager --no-daemon

Edited because the askubuntu interface is messing up CR/LF

share|improve this answer

xfce4-power-manager not started, applet not visible

Delete > Desktop configuration file:


Settings Manager / Session and Startup / Startup Applications

Item disabled:

Energy Management (power Management Xfce environment)

New item enabled:

      Name:        Xfce Power Manager (for example your name)
      Description: Power manager startup
      New command: xfce4-power-manager --no-daemon

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.