Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As stated above, I can't connect to my home wi-fi with natty but can with Windows 7. The strange thing is I that I have gotten it to connect to other password protected networks with natty, it's just mine that it dosn't like.

I am using a WPA2 pass-code with AES Encryption and all other devises work fine on my network. Laptop used is a Dell Latitude D430.

share|improve this question
When you note that you are unable to establish a wireless connection under Ubuntu 11.04, can you provide additional details? As much as I hate to ask the question, are you passing the correct password? – Kory Wnuk Jun 12 '11 at 20:23
I ran into some issues with the Dell Latitude line and Ubuntu, and using WPA2, but that was partly due to what card I had. What wifi card are you using? – Thomas Ward Jun 16 '11 at 14:56
Please provide more details. I have encountered a similar one on my notebook and it happened every time its not connected to the charger. It had something to do with the wi-fi power management. Apparently I had to turn it off permanently. – Candelight Dec 31 '11 at 16:14

Do you have an Intel wireless network card?

If yes, have a look in the router configuration whether it uses 802.11n or ~b or ~g. Lately I had a problem with this. Although I got connected to my WLAN I couldn't reach any other PC or the internet. With some help of the guys in my local IRC channel we figured out that Intel cards have problems with 802.11n in Linux. So I forced my router to use b/g instead and then it worked.

This may differ from your problem but who knows which kind of problems occur with this buggy Intel driver.

share|improve this answer

I've had a similar problem and solved it using a different connection manager called "wicd". (wicd-gtk in the software center, you may need to uninstall network-manager and network-manager-gnome for it to work.) Turns out, the standard network-manager causes some problems with certain routers.

share|improve this answer

I'm running Ubuntu 11.10 on a Dell Latitude D630. Here's some output from MY system:

sudo lshw -c network -short
H/W path Device Class Description
/0/100/1c.1/0 network BCM4311 802.11b/g WLAN

Is yours similar? I've been able to connect to an Apple Airport base station WPA2/PSK and configure the connection, take my wireless connection up and down with Network Manager, and an occasional sudo rmmod b43, or sudo modprobe b43. The chipset name ("BCM4311" in my case) will help in further solution search.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.