Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have used kubuntu(10.04 & 12.04) and firefox for many years. Recently I upgraded to 14.04 and firefox will no longer open local html files. I installed chromium and it seems to work properly. Since firefox has always been my preferred browser is anyone aware of a fix for this problem?

share|improve this question
    
How are you trying to open the local html files? You can use File -> Open file when in firefox and also right click on the file and choose the application that you want to open the file with. Also, what do you get when you try to open it? What do you get when you try to open it from a terminal using firefox filename? –  i08in May 24 at 1:50
    
Check whether you're trying to work offline in 'file'->'work offline' menu and uncheck it. –  Parto May 24 at 6:25

1 Answer 1

Yeah, please share what is the exact error that you experience.

By the way, you could possibly try resetting the settings in Firefox. To do so, go to the new config menu, open the Help menu, and then Troubleshooting Information. Click Reset Firefox. And then check whether you are able to view local html files.

Firefox will reset all your data (including addons, themes and profile data), and your Firefox installation will be like a brand new one. If everything works fine, then you can re-install your favorite addons.

Otherwise, you could try deleting (or backing up) your profiles directory, which is housed in $HOME/.mozilla/firefox.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.