Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Word on the street is that "gtk-enable-mnemonics" has been deprecated since version 3.10, and I am not at all sure how to get my application to display mnemonics.

They will only display if I press the alt key.

Please see here:

I have tried everything suggested in this article in regards to settings.ini, switching the bool to the opposite:

Related:

share|improve this question

2 Answers 2

To "disable" mnemonics for Nautilus 3.10.1 on Ubuntu 14.04 which uses GTK3:

  1. Create the following path & file if it doesn't already exist.
    /home/YOURUSERNAME/.config/gtk-3.0/settings.ini
  2. Then add:
    [Settings]
    gtk-enable-mnemonics = 0
  3. Then logout and log back in.

Sources:
* https://mail.gnome.org/archives/gtk-list/2011-March/msg00108.html
* https://developer.gnome.org/gtk3/stable/GtkSettings.html

p.s. Note that the GTK docs say you should have an environment variable called XDG_CONFIG_HOME but I didn't have one. I did have an existing ~/.config/gtk-3.0 folder and it appears it is looking there by default, without the environment variable.

share|improve this answer
up vote 0 down vote accepted

I think I was changing the wrong theme. Oops.

Steps followed.

http://stackoverflow.com/a/24095212/2026508

Change from: gtk-auto-mnemonics = 0 <---- Disabled

Change to: gtk-auto-mnemonics = 1 <---- Enabled

In GTK3 change in settings.ini: /usr/share/themes/CURRENT_THEME_NAME/gtk3.0/settings.ini

In GTK2 change in gtkrc: /usr/share/themes/CURRENT_THEME_NAME/gtk2.0/gtkrc

But make sure it is the correct/current theme.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.