Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a desktop with Ubuntu 7.10 installed, and I would like to use the old Firefox that comes with it and it's the only one working for certain online banking pages, and use the new Firefox 4 for newer HTML5 pages. How can I have both working side to side?

Thank you

share|improve this question
If you're not stuck on firefox, Chromium or Opera might work... I don't know why in the world you wouldn't upgrade from 7.10, though. – Daniel Jun 5 '11 at 17:02
There should be no reason for you to limit yourself to an older version of Firefox. FF4 should be enough by itself to do everything on the web. – Abhay Rana Jun 5 '11 at 17:03
up vote 2 down vote accepted

This may be a solution to your problem:

share|improve this answer

I wouldn't be too surprised if you can't find a PPA, etc. to work with 7.10, because it relies on someone maintaining it.

You can download firefox yourself ( You'll get a package which has already been compiled, and you can extract it to '/opt/firefox' and make a link to the executable.

Firefox can be a little funny with its dependencies, however, and you may find yourself needing extra libraries outside of the 7.10 repositories. In short, this could end up becoming quite involved; and I wouldn't attempt it if you're not too sure about the more detailed workings of Ubuntu.

Note that it will now be up to you to keep your browser updated, as you're outside the reach of aptitude, etc. and with something like a web browser, i recommend you keep an eye out for new versions.

share|improve this answer
on a side note ubuntu 7.10 is no longer supported, so you may not be getting critical updates. unlike windows, 11.4 (natty) is probably (subjective as these measurements are) no more resource demanding than 7.10 and is actively supported. If you want stability over cutting edge (and still want to get firefox 4 and other updates,) upgrade to the latest LTS (lucid, 10.4) which is supported until 2013. – thomas michael wallace Jun 5 '11 at 19:43

From the requirements for Firefox 4:

Firefox will not run at all without the following libraries or packages:

    GTK+ 2.10 or higher
    GLib 2.12 or higher
    Pango 1.14 or higher
    X.Org 1.0 or higher (1.7 or higher is recommended)
    libstdc++ 4.3 or higher

Let's check these dependencies:

I'm surprised that it even works with such an old version. So, technically, you should be able to use Firefox 4. Follow the instructions on How to install Firefox 3.6 and 4.0 in parallel?

If you've the possibility, I suggest you to upgrade to the latest version (11.04 Natty) or the LTS 10.04 Lucid.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.