Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  • Xubuntu 14.04

Hi,

first some code bits which I think are relevant:

$ sudo efibootmgr
BootCurrent: 0000
Timeout: 3 seconds
BootOrder: 0000,0003,0004
Boot0000* ubuntu
Boot0003* Hard Drive 
Boot0004* CD/DVD Drive 

$ sudo lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 931,5G  0 disk 
├─sda1   8:1    0   128M  0 part 
├─sda2   8:2    0 157,7G  0 part 
├─sda3   8:3    0 586,3G  0 part 
├─sda4   8:4    0    30G  0 part /
├─sda5   8:5    0 157,3G  0 part /home
└─sda6   8:6    0   100M  0 part /boot/efi
sr0     11:0    1  1024M  0 rom  

$ sudo blkid
/dev/sda2: UUID="C8C8DAE9C8DAD4B2" TYPE="ntfs" 
/dev/sda3: LABEL="Data" UUID="9AE4BBDEE4BBBB39" TYPE="ntfs" 
/dev/sda4: UUID="6ff82639-0387-4fe0-a9ea-d3d58b94358f" TYPE="ext4" 
/dev/sda5: UUID="6e6e2000-fa00-4eda-a1eb-07f1b3fdd9e0" TYPE="ext4" 
/dev/sda6: UUID="B0CD-A57E" TYPE="vfat" 
john@xubuntubox:~$ 

Whenever I enter GRUB and boot into my Windows 7 installation, it adds itself to spot 0001 in the EFI menu and apparently gets set as the default boot target. So I have to enter the EFI settings on boot, select ubuntu for the GRUB menu and then can use Xubuntu again. So far so good. After a new sudo efibootmgr I usually run sudo efibootmgr -b 0001 -B to remove the Windows entry.

After a short while (can't say how long exactly), I always get a system error. Ubuntu keeps functioning fine though. Then when I choose to shut down via the Xfce GUI, the PC goes to the bootscreen, has the circle spinning and then the spinning suddenly stops. The fans are still running but the machine sounds like it's off otherwise.

How can I fix this?

However when I

share|improve this question

1 Answer 1

There's no need to remove the Windows entry from the firmware's built-in boot manager. If Windows is setting itself as the default boot loader (which you don't explicitly say it's doing, but might be why you're removing its entry), see this question/answer for a solution.

The system error is probably unrelated to this, but I can't be sure. Can you provide more details, like an error message? You'll get better diagnostics on the shutdown problem if you start up without the quiet splash kernel options, which are enabled by default. You can remove them in GRUB by hitting e to edit the options before booting.

share|improve this answer
    
After some time, I had to boot into Windows again. At some boot instance into Linux after that I removed the Windows entry again and the error did not occur. The error does not occur each time I remove the boot entry. I think it is related to the following: It might occur on the first boot into Linux only... in combination with running dist-upgrade after I removed the Windows entry. If more happens, I'll post again. –  henry Jun 10 at 20:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.