Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have done a clean Natty install having bought a new SSD and find that in applications (ahem) such as Minecraft, and in the default web browser Firefox, the mouse scrolls too far .

So for example in Minecraft the mouse wheel jumps multiple items rather than one with each mouse wheel roll. With Firefox the page leaps quite a distance with each mouse wheel roll.

Any ideas where I might adjust this?

share|improve this question
1  
Hello, if you have fully updated your system then this could be related to this bug. Not sure though. bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/791596 –  user8592 Jun 5 '11 at 16:31
    
Firefox scroll rate: xahlee.blogspot.com/2011/05/… For changing X.org global scroll rate: askubuntu.com/questions/22589/… Did you search before posting? –  Janus Troelsen Jun 7 '11 at 13:06
    
It's not a global setting that's the problem, or one with Firefox. It's that the JVM is reporting double ticks for each event. –  Ken Oct 17 '12 at 16:29

2 Answers 2

As a workaround, try unplugging your mouse and plugging it back in. I run into this issue when the mouse is plugged into my laptop when Ubuntu boots up. Using this workaround fixes the issue for me.

share|improve this answer
6  
This fixed it for me and I was pretty suprised! This fix was kinda surreal and like most folks I didn't believe it until I did it: Turns out some MS mice have a scrollwheel bug. As Tarek found, > Try unplugging the USB cable / dongle then plug back in. That's it! Now my mouse moves normally (one line at a time, not half a screen!) This worked even though I use a 4-port screen/keyboard/mouse KVM box ! Yeah! –  Michael Durrant Feb 6 '12 at 16:42
    
Thoughts on mice that don't plug in (ie, bluetooth)? –  Ken Oct 17 '12 at 0:43
    
Disconnect/Reconnect? TBH I have no clue why that works, but I imagine issue seems has something to do with a hand-off of the mouse control between two subsystems; the second taking the (incorrect) parameters from the first. –  Tarek Fadel Dec 4 '12 at 12:28

I found this project which aims to fix this problem, without having to unplug and replug the hardware: http://sourceforge.net/projects/resetmsmice

This package, resetmsmice, fixes scroll wheel issues with certain Wireless Microsoft mice in X.org (includes KDE & Gnome applications), where the vertical wheel scrolls abnormally fast. Only needed if you dual boot between Microsoft Windows and some linux distro. Known to fix the vertical scroll wheel issue with the following models (and others related):

  • Microsoft Wireless Mouse 1000
  • Microsoft Wireless Optical Desktop 3000
  • Microsoft Wireless Mobile Mouse 3500
  • Microsoft Wireless Mobile Mouse 4000
  • Microsoft Comfort Mouse 4500
  • Microsoft Wireless Mouse 5000

This program basically just resets a setting in the mouse through usb communications and then exits. Runs when linux boots up or you can run it manually.

The project provides packages for Debian and RPM

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.