Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 13.10 and a couple of weeks ago I tried to upgrade to 14.04. However, during the process, the computer tuned off. So, the upgrade was not completed. Now I can't install anything and that's what I get in the terminal when I try to:

Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (< 2.18) but 2.19-0ubuntu6 is installed
 libc-dev-bin : Depends: libc6 (< 2.18) but 2.19-0ubuntu6 is installed
 libc6-dbg : Depends: libc6 (= 2.17-93ubuntu4) but 2.19-0ubuntu6 is installed
 libc6-dev : Depends: libc6 (= 2.17-93ubuntu4) but 2.19-0ubuntu6 is installed
 libgcc1-dbg : Depends: libgcc1 (= 1:4.8.1-10ubuntu9) but 1:4.9-20140406-0ubuntu1 is installed
 libpcre3-dev : Depends: libpcre3 (= 1:8.31-2) but 1:8.31-2ubuntu2 is installed
E: Unmet dependencies. Try using -f.

If I type 'apt-get -f install' that's what I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libasound2-dev libavahi-client-dev libavahi-common-dev libavcodec-dev libavformat-dev libavutil-dev libboost-date-time1.53.0
  libboost-signals1.53.0 libcmis-0.3-3 libdbus-1-dev libgsl0-dev libharfbuzz-dev libilmbase-dev libjbig-dev liblzma-dev libmgl-qt5
  libmgl-wx5 libopencv-gpu2.4 libopencv-stitching2.4 libopencv-superres2.4 libopencv-ts2.4 libopencv-videostab2.4 libopenexr-dev
  libraw1394-dev libraw1394-tools libssl-doc libswscale-dev libtiffxx5 libwayland-dev libxcomposite-dev libxkbcommon-dev lsb-security pax
  x11proto-composite-dev
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  bluez-cups build-essential comerr-dev cups f2c flite1-dev fort77 freehdl g++ g++-4.4 g++-4.6 g++-4.7 g++-4.8 gfortran-4.6 ghc ghc-doc
  ghc-haddock ghc6 google-earth-stable hplip krb5-multidev libatk-bridge2.0-dev libatk1.0-dev libboost-dev libboost-signals-dev
  libboost-signals1.49-dev libboost1.49-dev libc-bin libc-dev-bin libc6-dbg libc6-dev libcaca-dev libcairo2-dev libcups2-dev libcv-dev
  libcvaux-dev libdc1394-22-dev libexpat1-dev libf2c2-dev libfontconfig1-dev libfreetype6-dev libftdi-dev libgcc1-dbg libgcrypt11-dev
  libgdk-pixbuf2.0-dev libghc-data-default-dev libghc-data-default-doc libghc-dlist-dev libghc-dlist-doc libghc-extensible-exceptions-dev
  libghc-mtl-dev libghc-mtl-doc libghc-random-dev libghc-transformers-dev libghc-transformers-doc libghc-utf8-string-dev libghc-x11-dev
  libghc-x11-doc libghc-x11-xft-dev libghc-x11-xft-doc libghc-xmonad-contrib-dev libghc-xmonad-contrib-doc libghc-xmonad-dev
  libghc-xmonad-doc libglib2.0-dev libgnutls-dev libgstreamer1.0-dev libgtk-3-dev libgtk2.0-dev libhighgui-dev libjpeg-dev
  libjpeg-turbo8-dev libjpeg8-dev libkrb5-dev liblua5.2-dev libmgl-dev libmng-dev libncurses5-dev libopencv-calib3d-dev
  libopencv-contrib-dev libopencv-core-dev libopencv-dev libopencv-features2d-dev libopencv-flann-dev libopencv-gpu-dev
  libopencv-highgui-dev libopencv-imgproc-dev libopencv-legacy-dev libopencv-ml-dev libopencv-objdetect-dev libopencv-ocl-dev
  libopencv-ocl2.4 libopencv-photo-dev libopencv-stitching-dev libopencv-superres-dev libopencv-ts-dev libopencv-video-dev
  libopencv-videostab-dev libpango1.0-dev libpcre3-dev libpng12-dev libpulse-dev libpython-dev libpython2.7-dev libpython3-all-dev
  libpython3-dev libpython3.3-dev libqt3-mt-dev libsdl1.2-dev libslang2-dev libssl-dev libstdc++-4.8-dev libstdc++6-4.4-dev
  libstdc++6-4.6-dev libstdc++6-4.7-dev libtiff5-dev libtool libusb-dev libxft-dev lsb-core nvidia-319-updates printer-driver-gutenprint
  printer-driver-hpcups printer-driver-postscript-hp python-dev python2.7-dev valgrind zlib1g-dev
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  libc-bin
0 upgraded, 0 newly installed, 128 to remove and 64 not upgraded.
After this operation, 1,227 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'

I didn't do it as I wasn't sure about it.

What can I do? Can it be solved?

share|improve this question
    
possible duplicate of How do I resolve unmet dependencies? –  chaos May 23 at 6:53
1  
Never type "Yes, do as I say!" –  Avinash Raj May 23 at 7:07
1  
At this point, I would check to see if /etc/apt/sources.list contains only trusty entries (no saucy) and see what apt-get upgrade followed by apt-get dist-upgrade does (followed by repeated calls to these methods). –  saiarcot895 Jun 11 at 19:44
    
Could you add the output of sudo apt-get check and sudo dpkg -C. –  Braiam Jun 11 at 20:00
    
As saiarcot895 said, also check you have no petra entries, only qiana in /etc/apt/*.list and /etc/apt/sources.list.d/*.list –  chech Aug 14 at 18:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.