Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to do a simple provisioning through juju-gui, i.e., Mysql and Wordpress combo; however, when I press the deploy button, I get the following notification:

Error deploying mysql
Could not deploy the requested service. Server responded with: cannot download charm "cs:precise/mysql-44": Cannot access the charm store. Are you connected to the internet? Error details: Get https://store.juju.ubuntu.com/charm-info?charms=cs%3Aprecise%2Fmysql-44: dial tcp 91.189.95.66:443: connection timed out

Similar message is observed, under /var/log/juju/all-machines.log:

machine-0: 2014-05-22 17:19:19 DEBUG juju.state.apiserver apiserver.go:127 -> [A] user-admin 2m7.308014762s {"RequestId":25,"Error":"cannot download charm \"cs:precise/mysql-44\": Cannot access the charm store. Are you connected to the internet? Error details: Get https://store.juju.ubuntu.com/charm-info?charms=cs%3Aprecise%2Fmysql-44: dial tcp 91.189.95.67:443: connection timed out","Response":{}} Client[""].ServiceDeploy

Here is what I get from ping

ubuntu@node2:/var/log/juju$ ping 91.189.95.67:443
ping: unknown host 91.189.95.67:443
ubuntu@node2:

MAAS server has 2 nics, one public facing, and the other for maas communication. The target node has a single nic connected to maas network. (side note - I tried experimenting with 2 nics on target node, one for outside and one for maas, by defining new gw and routing table. Though the target node was able to see the outside world; however, its communication with maas server got all messed up. So gave up on that.)

Here is target node's network setup:

ubuntu@node2:/var/log/juju$ more /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 10.0.0.10
search maas
ubuntu@node2:/var/log/juju$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10-0-0-10.maas  0.0.0.0         UG    0      0        0 eth1
10.0.0.0        *               255.255.255.0   U     0      0        0 eth1
ubuntu@node2:/var/log/juju$ 

All hints are welcome.

share|improve this question
    
Checked this with wireshark on, and noted that wordpress charm is attempting to directly access an outside address, i.e., the charm store. Tried couple of ssh tunnels, with not much luck. Will try with a second nic. –  user281985 May 26 at 18:05
    
Hi there i got the same problem, but i see no one answered you. Did you perhaps figure out the answer on your own...please help –  user313048 2 days ago
    
My problem was that I thought MAAS server would resolve external accesses. It doesn't. Ended up connecting MAAS's router, where all nodes are connected, to an external IP port, i.e., let the router resolve all external requests. –  user281985 14 hours ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.