Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I know this is asked often but nothing seems to work for me. Every time I try to update I get the following:

sudo apt-get update
Get:1 http://archive.ubuntu.com precise Release.gpg
Get:2 http://ppa.launchpad.net precise Release.gpg
Get:3 http://archive.ubuntu.com precise Release                            
Get:4 http://ppa.launchpad.net precise Release.gpg                         
Get:5 http://ppa.launchpad.net precise Release                              
Ign http://archive.ubuntu.com precise Release                               
E: GPG error: http://archive.ubuntu.com precise Release: The following signatures were invalid: NODATA 1 NODATA 2

The only way I can successfully execute

sudo apt-get update

is by removing ALL software sources (which is pointless).

Regardless of whatever software source I use (official ubuntu or some other PPA) I get the same errors.

So far I have tried:

  1. Changing the server from MAIN to some other . . . no joy
  2. The suggested fixes from here, here, here, and here.

Nothing seems to work. It seems that all my key data is missing and I can't figure out how to get it back.

Any help would be very appreciated !

share|improve this question

marked as duplicate by Eliah Kagan, KasiyA, Sylvain Pineau, Eric Carvalho, muru Oct 7 at 0:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Thanks for the suggestion 123456 but as I said I have tried changing the server with no joy. –  Fido May 22 at 16:33

1 Answer 1

Okay, some may say this was a stupid error on my part but I'm noting this here for anyone who may get similar issues.

If trying the solutions in the links I provided above did not work for you then chances are your system is behind a proxy.

I accidentally put my system behind a proxy when using a particular network extender this one if you curious.

When your system is put behind a proxy and it is not configured to be that way you will get these strange GPG errors. So your choices are to reconfigure to work through a proxy or to get rid of the proxy (I chose the latter).

NOTE: A simple way to confirm that your system is behind a proxy is to ping a website and observe the IP or name of the from portion of the reply. If the from portion is from an unexpected address then you may be accidentally behind a proxy as I was.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.