Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Update: further details related to the issue in this other question.

I'm able to boot my laptop only adding acpi=off as kernel parameter in grub configuration file. Without this parameter the system simply hangs forever on Ubuntu splash screen.

Hardware: HP Pavilion dv6-6008el

O.S.: Ubuntu Natty

$ uname -a
Linux tk 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011
x86_64 x86_64 x86_64 GNU/Linux

I'd really don't want to disable acpi support completely, as this generates annoying side effects like losing the ability to manage the power state of the laptop such as battery level, to cite one. Btw, this dv6 model has dual graphics and if I understand correctly vga_switcheroo requires acpi to switch between integrated Intel and composite ATI.

I tried to debug ACPI using the official Ubuntu guide but no luck, I still have to use acpi=off because less invasive options like acpi=ht, pci=noacpi, etc. don't work.

I have removed splash, quiet and acpi=off (this way acpi is enabled) from grub and the boot process stops at this point:

[cut]
* Starting AppArmor profiles
* Setting sensors limits
* Stopping System V initialisazion compatibility
* Starting System V runlevel compatibility
* Stopping automatic crash report generation
* Starting eCryptfs
* Starting restore sound card(s') mixer state(s)
* Starting ACPI deemon
* Starting anac(h)ronistic cron
* Starting kernel messages
* Stopping eCryptfs
* Starting regular background program processing daemon
* Starting deferred execution scheduler
...
* Stopping save kernel messages

If acpi=off the system stops here... otherwise the mouse pointer appears and I can log in (but /proc/acpi doesn't exist).

Please let me know what I have to do to solve the issue, I want to get rid of acpi=off setting.

Thanks

share|improve this question
    
I know this may sound strange - but I have seen some people comment that the 32bit desktop works better than 64bit - and visa versa. –  fossfreedom Jun 5 '11 at 13:24
    
I also have the same problem on an HP Mini 110. I also noticed that I have such problem on a Dell Inspiron 530 desktop. Looks to me like there has been a major change in Ubuntu that is affecting many users. Hopefully, someone will find a fix. –  jfmessier Jun 6 '11 at 1:14
    
@jfmessier I'm working on this, currently trying to enable acpi debug. Out of curiosity, do you have the /proc/acpi? –  Guandalino Jun 6 '11 at 11:57
    
I re-installed 10.10 on it, so that I have something that can work. But if you tell me (by email) what to look for, I will certainly do it. I can reinstall 11.04 on a spare hard disk. you can contact me at "jf at messier dot ca". –  jfmessier Jul 7 '11 at 1:55

1 Answer 1

There is a complete man-page for this at Ubuntu. Get it here

http://manpages.ubuntu.com/manpages/natty/man4/acpi_hp.4freebsd.html

share|improve this answer
    
1. reading the BUGS section at the bottom of the page it seems there are important side effects; 2. my platform is 64bit. But I'll try anyway, thanks! –  Guandalino Feb 25 '12 at 7:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.