Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have managed to install the nvidia-331-updates drivers on my Lenovo W530, and if I start nvidia-settings, it says:

** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes

Which is great. Furthermore, my xrandr setup seems just fine:

# xrandr
Screen 0: minimum 8 x 8, current 3600 x 1080, maximum 16384 x 16384
VGA-0 disconnected primary (normal left inverted right x axis y axis)
LVDS-0 disconnected (normal left inverted right x axis y axis)
DP-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 478mm x 300mm panning 3600x1080+0+0
   1680x1050      60.0*+
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1280x800       74.9     59.8  
   1152x720       60.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)
LVDS-1-0 connected 1920x1080+0+0 344mm x 193mm
   1920x1080      60.0*+   59.9     50.0  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0     60.0  
   960x720        60.0  
   928x696        60.1  
   896x672        60.0  
   960x600        60.0  
   960x540        60.0  
   800x600        60.0     60.3     56.2  
   840x525        60.0     59.9  
   800x512        60.2  
   700x525        60.0  
   640x512        60.0  
   720x450        59.9  
   640x480        60.0     59.9  
   680x384        59.8     60.0  
   576x432        60.1  
   512x384        60.0  
   400x300        60.3     56.3  
   320x240        60.1  
VGA-1-0 disconnected
  1680x1050 (0x48)  146.2MHz
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock   65.3KHz
        v: height 1050 start 1053 end 1059 total 1089           clock   60.0Hz
  1280x1024 (0x4c)  108.0MHz
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock   64.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   60.0Hz
  1024x768 (0x53)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x5a)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x63)   25.2MHz
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   59.9Hz

The contents of xorg.conf are as they should be:

# cat /etc/X11/xorg.conf
Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
EndSection

But when I run nvidia-settings, it simply clones the screen, and will not let me modify the setting. I want to extend across to the secondary screen when it is plugged into the display port.

EDIT:

When I run the following command:

# xrandr --output LVDS-1-0 --auto --output DP-0  --mode 1680x1050 --right-of LVDS-1-0 --verbose

it says :

crtc 0:    1680x1050   60.0 +1920+0 "DP-0"
crtc 4:    1920x1080   60.0 +0+0 "LVDS-1-0"

and the following is appended to Xorg.0.log:

[   121.934] (II) NVIDIA(GPU-0): Display (BenQ BL2201 (DFP-1)) does not support NVIDIA 3D
[   121.934] (II) NVIDIA(GPU-0):     Vision stereo.
[   121.965] (II) NVIDIA(GPU-0): Display (BenQ BL2201 (DFP-1)) does not support NVIDIA 3D
[   121.965] (II) NVIDIA(GPU-0):     Vision stereo.
[   121.965] (II) modesetting(G0): EDID vendor "LEN", prod id 16562
[   121.965] (II) modesetting(G0): Printing DDC gathered Modelines:
[   121.965] (II) modesetting(G0): Modeline "1920x1080"x0.0  139.00  1920 1980 2028 2050  1080 1090 1100 1130 -hsync -vsync (67.8 kHz eP)
[   121.965] (II) modesetting(G0): Modeline "1920x1080"x0.0  115.83  1920 1980 2028 2050  1080 1090 1100 1130 -hsync -vsync (56.5 kHz e)
[   121.996] reporting 7 10 51 392
[   122.018] (II) NVIDIA(0): Setting mode "DP-0: nvidia-auto-select @1680x1080 +1920+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"
[   122.101] (II) NVIDIA(0): Setting mode "DP-0: nvidia-auto-select @3600x1080 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"
[   122.184] reporting 7 10 51 392
[   122.192] reporting 7 10 51 392
[   122.209] reporting 7 10 51 392
[   122.210] reporting 7 10 51 392
[   122.210] reporting 7 10 51 392
[   122.210] reporting 7 10 51 392
[   122.210] reporting 7 10 51 392
[   122.211] reporting 7 10 51 392
[   122.211] reporting 7 10 51 392
[   122.211] reporting 7 10 51 392
[   122.212] reporting 7 10 51 392
[   122.212] reporting 7 10 51 392

it looks like it is setting the DP-0 (external) screen to a very large display, with the same origin (so cloned)

share|improve this question

1 Answer 1

You should be able to do this through nvidia-settings but if not, try this xorg.conf:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia" 0 0
    Inactive "intel"
    Option         "Xinerama" "0"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
EndSection


Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
    Option         "metamodes" "DP-0: 1680x1050, LVDS-1-0: 1920x1080"
    Option         "TwinViewOrientation" "RightOf"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
EndSection

Alternatively, try this command:

xrandr --output DP-0 --mode 1680x1050 --output LVDS-1-0 --mode 1920x1080 --right-of DP-0
share|improve this answer
    
Neither of these methods worked. But they didnt not work : KDE can configure the screens just fine. I need to look into how to configure AwesomeWM properly. –  Tom Macdonald May 23 at 8:25
    
@TomMacdonald the xrandr should work. The xorg.conf I'm not that sure about. I tried to guess based on my own setup. You should be able to build the correct xrandr command. What happened with the one I suggested? –  terdon May 23 at 8:42
    
the xrandr command is not working. But I think that something is setting up the screen as a clone before awesome gets there, if you see what I mean. Then the xrandr cannot override the current setup for some reason. The xrandr command: 'xrandr --output LVDS-1-0 --auto --output DP-0 --mode 1680x1050 --right-of LVDS-1-0' –  Tom Macdonald May 23 at 8:50
    
@TomMacdonald in that case I'm stumped. I've never come across anything that xrandr can't override. The only other suggestion I can think of is to remove the second screen entry from xorg.conf. There should be only one for an extended screen layout as I recall. That should still have been overridden by xrandr though. –  terdon May 23 at 8:57
    
Hmm ok. It may possibly be a carry over from my awesome config. I'll check there. –  Tom Macdonald May 23 at 8:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.