Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new in this forum.

I know, that this is an old problem and I have been reading other questions regarding this. However, I've been unable to find the solution.

I've been trying to install Ubuntu 14.04 on my Asus Vivobook F200MA machine from USB, but the screen goes black, if I choose any of the options. It is a new machine, with only freedos on it.

If I follow the instructions on

My computer boots to a black screen, what options do I have to fix it?

it still doesn't work.

SATA is set to AHCI, Secure Boot is disabled, CSM is enabled.

Do you have any ideas, how I could install it?

Edit:

I have tried:

  • checking the usb for errors (no errors),
  • verified the integrity (alright),
  • disabled the secure boot
  • enabled csm
  • set SATA to AHCI from the menu (try without installing, install and check for defects) because the screen goes black.
share|improve this question
    
What have you done of the suggestions? You should try the nomodset parameter. –  TuKsn May 22 '14 at 7:44
    
Thanks for the answer! Yes, I've tried it, but I can't access ubuntu live cd, the screen goes black as well. –  altonis May 22 '14 at 8:13

4 Answers 4

I had this problem and solved using the nomodeset mentioned by @Xubu-Tur along with the nolapic. This last one was necessary otherwise it woudn't work, but I am assuming you can get to the installation window (it is not clear in your question), like shown below:

enter image description here

EDIT:

I see. I think the options beneath allow you to edit the boot parameters. If that is the case, then you can set the boot parameters adding "nomodeset" and "nolapic" to the same place of the "quiet" and "splash". In the end it should be something like (...) quiet splash nomodeset nolapic (...). In the link you provided in the question there is an example (the guy removed the quiet splash, but I don't think that is necessary).

Boot Parameters

share|improve this answer
    
I'm sorry I wasn't clear before: I can't get into this menu. All I get is menu like this pix.toile-libre.org/upload/original/1347445084.png If I understand it correctly, it is booting in EFI mode. –  altonis May 22 '14 at 9:44
    
I updated the answer (maybe you already saw. Just add this here to document for others). –  infostacker May 22 '14 at 13:50
    
I tried writing "quiet splash nomodeset nolapic" in the boot parameters. I also tried removing "quiet splash" and replacing it with "nomodeset nolapic". It still doesn't work. However, now it shows commands running for a split second, but then restarts and goes to black screen. Is it possible that I replaced wrong? I left one space between each parameter (nomodeset nolapic) and did not delete any of the "--" after the parameters.. –  altonis May 22 '14 at 21:15
    
Try to include one more option: acpi=off. Regarding the spaces you got it right. So now it should be (...) quiet splash acpi=off nolapic nomodeset (...). Try in this order, just in case. –  infostacker May 22 '14 at 23:01
    
I got to the Ubuntu loading screen, but after a minute it showed me: BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash) Enter 'help' for a list of built-in commands. (initramfs) Unable to find a medium containing a live file system. I verified the USB stick before, it didn't have any errors. –  altonis May 23 '14 at 6:46

I had the same problem today. What fixed it for me was to connect the monitor via VGA instead of the DVI connection that I had in place.

share|improve this answer

I tried all advices given about that "black screen" issue after having installed properly, with no faults, the installation wizard. None of them solved my problem.

The only thing that saved my Kubuntu 14.04, after restarting from the complete installation of software, was when I ran Bios setup, went to Boot page, selected as 1st Hard Disk Drive and 1st Boot Device my HDD.

Try it for other Linux Distributions also.

None of "nomodeset", "nouveau.noaccel=1", remove of "quiet splash --", setting grub on other HDD, Bios "Quick Boot = Off" and changing live usb solved it.

Also I realized that I could not set as disk to boot other HDD than the one of my previous Linux Distribution without receiving the error "grub-install /dev/sda failed". I wanted root and home partition on sdb (larger disk) while previously was on sda (smaller disk). To solve this problem I tried many things like the advices given on these pages:

How to find out which partition is Ubuntu installed on?

http://ubuntuhandbook.org/index.php/2013/11/reinstall-grub-ubuntu-wont-boot/

http://ubuntu.aspcode.net/view/635400140124705175127972/executing-grub-install-devsda5-failed-this-is-a-fatal-error

I ended using LVM on my old disk (sda), which I believe is a good solution (read about it: What is LVM and what is it used for?). Regarding the "black screen" issue, I suggest that you should try to make as 1st Hard Disk Drive and 1st Boot Device your HDD, on Bios Menu, after completing installation wizard and see if that helps you. Nothing to lose. Solved my problem Thank you all for the advice given!!!

share|improve this answer
    
This does not appear to be an answer. –  No Time Feb 24 at 0:57
    
Sorry, if I did not help and for the large text written above...I was just over-excited after my "Black screen problem" was solved and I thought myself obliged to tell others too, if that helps...Thank you again! –  Linuxerolas Feb 26 at 16:21
    
It is just really hard to read and tell where the answer is. You may want to put links used as sources near the bottom, or use asterisks maybe. It is just hard to see exactly where the answer is even though your links contain lots of useful information. –  No Time Feb 26 at 22:38
    
Ok...I understand now...Thanks for the advice given...I am just new on askubuntu.com...I will apply them directly on my next post, if any...Thanks!!! –  Linuxerolas Mar 3 at 20:55

You should use vga=normal nomodeset before the --. That should disable the frame buffer. Removing only quiet splash doesn't help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.