Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using ubuntu for a couple of weeks now and have been surviving without my touchpad.

I have Asus x450L laptop. Are there drivers available so my trackpad will function again?

It works on windows 8.1 but not on ubuntu. I tried reinstalling the synaptics and all sorts of things.

FINAL ANSWER EDIT: Check my answer it works. In short just update your bios and it will work.

share|improve this question

4 Answers 4

There's no solution right now.

I've made a blog post to summarize everything I know on this subject: Asus touchpad not detected under Ubuntu Linux. This bug affects at least Asus X450CC, X550CA, X550LB, X550LC, X550LD, X750LB.

share|improve this answer
    
Thanks a lot. I'm facing the same issue. Just bought an Asus X550LD yesterday. –  Manoj Jun 15 at 13:16

Work Around
Credit to Hans De Goede (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1314198/comments/31)

This should enable the mouse to work as a normal touchpad mouse, so no multi-touch.

You need to add a Kernel Boot Parameter to set the flag psmouse.proto=bare which will enable PS/2 Mouse Emulation mode on your touchpad.

To do this you can edit your default grub file.

sudo nano /etc/default/grub

Find the line that mentions GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (or something similar) and add the flag to the end of the quoted string.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.proto=bare"

Then save the file and run a grub update.

sudo update-grub

Then restart the system and (hopefully) enjoy your new touchpad in PS/2 Emulation Mode.

This is a temporary fix as Hans De Goede mentions, this isn't a trivial fix. If I'm reading the situation correctly, support for the software that handled the touchpad used in the ASUS 550 range (and some other models) was deprecated in 14.04 and a suitable replacement hasn't yet been developed. So for now we don't get multi-touch in 14.04.

Having struggled with this for a while and finding nothing but launchpad bug reports, I'm pretty happy to finally have a working touchpad even if it doesn't have multi-touch!

share|improve this answer

I had the same problem. Using Asus X450LD.

Touchpad not even detected in the System Settings GUI and not even appeared in xinput list. Tried all kinds of suggestions from this forum. And then. I tried one thing.

Update my BIOS. And it works!

Now, in my xinput list. I have :

ETPS/2 Elantech Touchpad                    id=13   [slave  pointer  (2)]

I hope this help.

share|improve this answer
    
Can you please provide a link to the BIOS file you used to upgrade? I'll give it a go on my asus to see if it works. –  Some_random_coder Jul 20 at 4:07
    
Sure, Go here. Choose 64/32 bits for Windows 8.1. Select the latest one. Bios 208. –  AFwcxx Jul 20 at 8:58
    
@Some_random_coder, besides touchpad. Is there any other problems that you are having with your mobo? My keyboard shortcut brightness and In-built Speaker not working [headphones works though]. Yours? –  AFwcxx Jul 20 at 9:14
up vote 0 down vote accepted

For those still stuck on this problem, just go to the ASUS website and update your bios and viola, it will fix the trackpad issues.

share|improve this answer

protected by Community 2 days ago

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.