Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get only a purple screen for the background during login. Not even the default warty background. Its been like that since I installed Ubuntu.

Ever since I came to know about the background of the login screen that is supposed to change with the user, I have been trying to activate it. Then I read that it should be activated by default, but since I didn't get any such screen, I searched for solutions.

I followed the steps here.

Still, I couldn't figure out to fix it.

I checked the log files in /var/log/lightdm/

I found these warnings in x-0-greeter.log:

Activating service name='org.a11y.atspi.Registry'
[+0.00s] DEBUG: unity-greeter.vala:435: Starting unity-greeter 13.10.3 UID=111 LANG=en_US.UTF-8
[+0.00s] DEBUG: unity-greeter.vala:438: Setting cursor
[+0.00s] DEBUG: unity-greeter.vala:452: Loading command line options
[+0.00s] DEBUG: unity-greeter.vala:480: Setting GTK+ settings
Successfully activated service 'org.a11y.atspi.Registry'

** (at-spi2-registryd:7017): WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (at-spi2-registryd:7017): WARNING **: Unable to register client with session manager
[+0.14s] DEBUG: unity-greeter.vala:503: Creating Unity Greeter

....

[+0.34s] DEBUG: Starting authentication for user subhrajit...
[+0.34s] DEBUG: Wrote 25 bytes to daemon

** (gnome-settings-daemon:7038): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
[+0.40s] DEBUG: Starting authentication for user subhrajit...

....

[+0.54s] DEBUG: background.vala:155: Error loading background: Failed to open file '/home/subhrajit/Pictures/Pictures/HD Wallpapers/Wallpaper 1080 (12).jpg': Permission denied

(gnome-settings-daemon:7038): power-plugin-WARNING **: Failed to run GetActive() function on screensaver: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.gnome.ScreenSaver' on object at path /org/gnome/ScreenSaver
[+0.80s] DEBUG: Connected to Application Indicator Service.
[+0.81s] DEBUG: unity-greeter.vala:177: starting system-ready sound

** (nm-applet:7055): WARNING **: Could not create object for /org/freedesktop/NetworkManager/Settings/1: uid 111 has no permission to perform this operation

** (nm-applet:7055): WARNING **: handle_property_changed: failed to update property 'available-connections' of object type NMDeviceEthernet.
[+0.95s] DEBUG: background.vala:117: Render of background  complete

....

[+3.69s] DEBUG: Starting session ubuntu
[+3.69s] DEBUG: Wrote 18 bytes to daemon

** (gnome-settings-daemon:7038): WARNING **: Name taken or bus went away - shutting down

(gnome-settings-daemon:7038): dconf-WARNING **: failed to commit changes to dconf: The connection is closed
** Message: PID 7055 (we are 7055) sent signal 15, shutting down...

(nm-applet:7055): libappindicator-WARNING **: Unable to send signal for NewStatus: The connection is closed

Hope this helps.

share|improve this question

1 Answer 1

The clue is: Error loading background: Failed to open file '/home/subhrajit/Pictures/Pictures/HD Wallpapers/Wallpaper 1080 (12).jpg': Permission denied

Insure that you have permission to read this file. See the man page for chmod or in nautilus right click, choose properties, permissions tab and adjust the permissions on the file accordingly. You will likely want to select all pictures you wish to use as background and apply this fix. Or apply chmod recursively across all pictures in the folder.

Try this:

sudo chmod 774 /home/subhrajit/Pictures/Pictures/HD Wallpapers/Wallpaper 1080 (12).jpg

share|improve this answer
    
Actually, that is the path to my wallpaper, which loads fine after I log in. –  Subhrajit Prusty May 22 at 17:04
    
If the data in the log you provided is no longer accurate, please update it. Thank you. –  Elder Geek May 22 at 17:08
    
No, its still the same. I meant that it is my desktop background. It loads fine after the login screen goes away, but still I get a purple background in my login screen. –  Subhrajit Prusty May 22 at 17:24
    
What do you expect to see on your login screen? –  Elder Geek May 22 at 17:27
    
My desktop wallpaper? Isn't that what unity-greeter is supposed to do? –  Subhrajit Prusty May 22 at 18:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.