Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I log out from a Gnome session (by clicking on the "power" button in the top panel and choosing "Log out...", I have to answer the "Are you sure..." question. How can I configure my system to avoid this question?

Since I already have performed two actions (clicking on the panel button, and selected the "Log out" item), it is quite probable that I actually want to log out. :)

share|improve this question
    
Just to play devil's advocate, being a list of actions "log out, switch user, restart, etc" it's not very hard to miss and accidentally select the wrong item, especially with a trackpad. –  tj111 Sep 24 '10 at 18:18
    
That's why I like the logout button on the panel. Especially since with several users there is lots of logging out, but almost no use of the other items in that menu. –  Dennis Sep 24 '10 at 20:29
add comment

4 Answers 4

up vote 4 down vote accepted

You can try the following command

gconftool-2 -s /apps/indicator-session/suppress_logout_restart_shutdown –t bool true

or open Configuration Editor and set it using the gui with below steps:

  1. Press Alt+F2 and enter "gconf-editor"
  2. Navigate to apps -> indicator-session
  3. Check the box next to the name "suppress_logout_restart_shutdown" on the right hand side pane.
  4. Exit Configuration editor.

More details can be found here.

share|improve this answer
    
For me the command there returns Must specify a type when setting a value (10.10) –  8128 Oct 16 '10 at 13:12
    
There was an error in the gconftool-2 invocation (using -type instead of --type or -t). Strangely, we happen to encounter it only now... it could be because this key was already present in 10.04 and removed in 10.10. Can you try gconftool-2 -g /apps/indicator-session/suppress_logout_restart_shutdown and post the output on your system ? (For now I have edited the answer in anticipation of this) –  koushik Oct 17 '10 at 1:19
    
It outputs true - but I had already changed the key using gconf-editor yesterday... –  8128 Oct 17 '10 at 7:04
    
OK, until someone can verify on a vanilla 10.10 install, I will assume the error was in the wrong usage of the long option syntax, which I have fixed now. –  koushik Oct 17 '10 at 11:58
add comment

There may be an easier way, but I always do the following.

Either in a terminal or by hitting ALT-F2 and entering run, start...
gconf-editor
select apps
select gnome-session
select options
uncheck logout_prompt

Then for each of my family members I right click on the panel
select Add To Panel
Add a logout button

Doesn't get any more convenient than that.

share|improve this answer
add comment

By far the easiest way is to use Ubuntu Tweak. No command-line. Just a simple checkbox.

share|improve this answer
    
Could you explain exactly what settings to set? –  hexafraction Aug 16 '12 at 19:02
add comment

Have you tried pressing Ctrl + Alt + Backspace? Works for me (GNOME classic without effects on Ubuntu 11.10).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.