Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Now I've actually been here with a similar question before - but was largely inspecific because I didn't know what I was really looking for.

However, onto the question. I have a laptop that I've had for a number of years, and every time without fail that I've attempted to install a Linux distribution onto it, it's spat it right back at my face - instead opting to show a flashing underscore where GRUB should live.

A number of suggestions to try a bunch of different distros from Crunchbang to Elementary to Debian to Fedora popped up, but unfortunately none of them would boot.

Now - it's an older laptop (3-4 years) by UK company Novatech. The motherboard is developed by CLEVO Co., and it has an Intel Core 2 Duo T6600 (2.2GHz) with 4GB of RAM and an Nvidia G105M (which I initially thought was the issue).

When you run the LiveUSB/CD of the operating system, it works fine - no issues whatsoever. In fact, it's arguably more compatible out of the box than Windows is (some hardware functions that need drivers on Windows don't on Ubuntu).

So I took it down to the differing factors - and a big one was that the USB stick I'm reading off of is set to FAT file system, instead of ext4 (which I thought maybe could be an issue if the developers of the laptop didn't really take much care to support Linux operating systems), and also its a USB stick. It's not the hard drive. I guess that's a pretty big difference in itself.

Also, on older versions of Ubuntu, it would briefly after BIOS screen display a piece of text: "GRUB Loading...", and it's remain there instead of just the flashing underscore.

I guess my overall question is - can certain hard-drives not 'have' ext4 partitions? Or can some hard drives be incompatible with Linux/GRUB? Or is it my hardware, and if so - why does it run fine off the memory stick? Would this be solved if I somehow installed Linux onto an NTFS or FAT partition (if that's possible, I imagine it is, with Linux being Linux).

Anyway, hopefully I didn't kill too many of your sanities with the wall of text.

Thanks in advance :)

share|improve this question
1  
Are you using amd64? –  bain May 21 at 13:41

2 Answers 2

All hard drives are compatible with Linux. The fact that you can successfully partition, format, and install Linux mean that the hard disk works. What your system seems to have a problem with is either installing or booting grub. Grub is not Linux, it is just a boot loader. It is possible that your hard disk has bad blocks, or a problematic SATA controller, but all of the evidence points to some problem with grub and the BIOS, which means you need to look at answers like:

  • How can I repair grub?

  • Go into your BIOS settings and make sure it is configured to boot from the hard drive and that any other potential boot devices are disabled (floppy disk etc. may appear in the BIOS, even if you do not have a floppy drive).

  • Install the latest Ubuntu LTS and just let it wipe the whole hard disk and do an automatic install. There are reports on the net of Novatech laptops failing to boot with older kernels which do then boot after updating.

  • There are also reports of grub1 failing to boot on some systems, so its worth trying grub2. Or try grub1 (grub legacy) if you have been failing with grub2.

  • Check your memory for errors

  • Check your hard drive for errors

  • Try installing another OS (Windows)

  • If you are using amd64 try i386 (or vice versa)

  • Boot from grub installed to a USB drive, see Ubuntu Wiki BootFromUSB

  • Try installing another boot loader instead of grub (syslinux or lilo, or even the DOS boot loader with NeoGRUB)

  • Report your problem on the Grub-devel mailing list. It may be possible to fix the source.

I came across reports of other Novatech laptop users having similar boot problems: one said his issue was fixed after a kernel update, another fixed it by installing LILO instead of GRUB. From what you describe, my guess is that if you install your /boot partition as ext2, and then install LILO, it will boot.

share|improve this answer

They actually should. hat kind of hard drive is it? Internal or external? I do the following settings.

HDD mode in Bios ACHI then a bootable CD that works fine. Some windows xp worked on ATI mode. Changing the mode might help. Press del or F2 just after you see initial screen then you can find the setting and change it. you must save and exit or enter F10 if it works esc works equally well. create partitions suitable for your needs and you are good to Go.

you can always return back or PM me if any Problem arises.

share|improve this answer
    
Thanks for the help, but what exactly do you mean 'changing the mode'? Are you referring to motherboard settings, because if so - the laptop doesn't have all that many of those, and there isn't one for "ACHI". There is one, however, for Installed OS, with the options as 'Windows' or 'Other', and selecting Other doesn't appear to make a difference at all. –  Chris Thomson May 21 at 13:48
    
Sorry for the late reply.. Actually I meant the changes to be done in boot setup using F2 or Del key. If your previous OS is XP this definitely needs to be done. write to me @ rohitdhamal@yahoo.com for urgent help. –  user283582 May 26 at 2:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.